Android SDK and Eclipse ADT on Fedora 16/15, CentOS/RHEL 6 - Comment Page: 3

This is guide howto install Android SDK Tools r16 and Eclipse ADT (Android Development Tools) Plugin on Fedora 16, Fedora 15, Fedora 14, Fedora 13, CentOS 6.2/6.1/6 and Red Hat (RHEL) 6.2/6.1/6. This Guide Contents 1. Preparing Your Development Computer and Install Required softwares 2. Install Andoid SDK 3. Install ADT Plugin for Eclipse 4. Configure Eclipse and Install Latest Android SDK with AVD Manager 5. Create Simple Android Test Project 1. Preparing Your Development Computer and Install Required softwares 1.1 Install Sun/Oracle Java 7 JDK/JRE 1.2 Install Eclipse SDK 3.7 (Indigo) 2. Install Andoid SDK 2.1 Change root user su - ## OR ## sudo...

104 comments on “Android SDK and Eclipse ADT on Fedora 16/15, CentOS/RHEL 6 - Comment Page: 3

1 2 3 4
    1. I was trying to create the Virtual Device, after I fill out all the option, I did click on Create AVD button and the console show to me this message
      2011-06-12 20:43:12 - SDK Manager] Error: null
      [2011-06-12 21:36:18 - SDK Manager] Failed to create the SD card.
      [2011-06-12 21:36:18 - SDK Manager] Failed to create sdcard in the AVD folder.

      and I cant create the device. What can I do to solve it?

      Reply
      • Hi LostAcapulco,

        Do you have write permissions on avd directory and enough free space for sdcard?

        Is your system 32-bit or 64-bit?

        Reply
        • Is 64bits, btw if I dont asign sd card and then I continued creating the Virtual Device, this can be created, but when I try to launch this message show to me. Failed to start emulator: Cannot run program “/opt/android-sdk//tools/emulator”: java.io.IOException: error=2, No such file or directory

          About permissions I cant see the the adv directory where is it located?

          Reply
          • Did you installed all 32-bit packages on your system (step 2.5)?

            
            yum install glibc.i686 glibc-devel.i686 libstdc++.i686 zlib-devel.i686 ncurses-devel.i686 libX11-devel.i686 libXrender.i686 libXrandr.i686
            

            ADV directory is normally located ~/.android/avd.

            By the way could you check your Android SDK location path, it should be /opt/android-sdk, not /opt/android-sdk/.

            Btw. could you also post output of following command:

            
            ls -la /opt/android-sdk/tools/
            
            Reply
            • output comand:
              ls -la /opt/android-sdk/tools/
              total 10168
              drwxrwxrwx. 5 12275 5000 4096 May 3 18:13 .
              drwxrwxrwx. 10 12275 5000 4096 Jun 12 21:22 ..
              -rw-rw-rw-. 1 12275 5000 323 May 3 18:13 adb_has_moved.txt
              -rwxrwxrwx. 1 12275 5000 3443 May 3 18:13 android
              drwxrwxrwx. 2 12275 5000 4096 May 3 18:13 ant
              -rwxrwxrwx. 1 12275 5000 1977 May 3 18:13 apkbuilder
              -rwxrwxrwx. 1 12275 5000 3179 May 3 18:13 ddms
              -rwxrwxrwx. 1 12275 5000 86930 May 3 18:13 dmtracedump
              -rwxrwxrwx. 1 12275 5000 1940 May 3 18:13 draw9patch
              -rwxrwxrwx. 1 12275 5000 7748160 May 3 18:13 emulator
              -rwxrwxrwx. 1 12275 5000 500976 May 3 18:13 etc1tool
              -rwxrwxrwx. 1 12275 5000 3229 May 3 18:13 hierarchyviewer
              -rwxrwxrwx. 1 12275 5000 22738 May 3 18:13 hprof-conv
              -rwxrwxrwx. 1 12275 5000 1939 May 3 18:13 layoutopt
              drwxrwxrwx. 5 12275 5000 4096 May 3 18:13 lib
              -rwxrwxrwx. 1 12275 5000 17779 May 3 18:13 mksdcard
              -rwxrwxrwx. 1 12275 5000 2262 May 3 18:13 monkeyrunner
              -rw-rw-rw-. 1 12275 5000 206311 May 3 18:13 NOTICE.txt
              drwxrwxrwx. 5 12275 5000 4096 May 3 18:13 proguard
              -rw-rw-rw-. 1 12275 5000 65 May 3 18:13 source.properties
              -rwxrwxrwx. 1 12275 5000 1549093 May 3 18:13 sqlite3
              -rwxrwxrwx. 1 12275 5000 3044 May 3 18:13 traceview
              -rwxrwxrwx. 1 12275 5000 198992 May 3 18:13 zipalign

              executing installation package:

              # yum install glibc.i686 glibc-devel.i686 libstdc++.i686 zlib-devel.i686 ncurses-devel.i686 libX11-devel.i686 libXrender.i686 libXrandr.i686
              Loaded plugins: langpacks, presto, refresh-packagekit
              adobe-linux-i386 | 951 B 00:00
              adobe-linux-i386/primary | 12 kB 00:00
              updates/metalink | 15 kB 00:00
              adobe-linux-i386 18/18
              Setting up Install Process
              Resolving Dependencies
              --> Running transaction check
              ---> Package glibc.i686 0:2.14-2 will be installed
              --> Processing Dependency: glibc-common = 2.14-2 for package: glibc-2.14-2.i686
              --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.14-2.i686
              --> Processing Dependency: libfreebl3.so for package: glibc-2.14-2.i686
              ---> Package glibc-devel.i686 0:2.14-2 will be installed
              --> Processing Dependency: glibc-headers = 2.14-2 for package: glibc-devel-2.14-2.i686
              ---> Package libX11-devel.i686 0:1.4.3-1.fc15 will be installed
              --> Processing Dependency: pkgconfig(xcb) >= 1.1.92 for package: libX11-devel-1.4.3-1.fc15.i686
              --> Processing Dependency: pkgconfig(xcb) for package: libX11-devel-1.4.3-1.fc15.i686
              --> Processing Dependency: pkgconfig(kbproto) for package: libX11-devel-1.4.3-1.fc15.i686
              --> Processing Dependency: libX11.so.6 for package: libX11-devel-1.4.3-1.fc15.i686
              --> Processing Dependency: pkgconfig(xproto) for package: libX11-devel-1.4.3-1.fc15.i686
              --> Processing Dependency: libX11-xcb.so.1 for package: libX11-devel-1.4.3-1.fc15.i686
              ---> Package libXrandr.i686 0:1.3.1-2.fc15 will be installed
              --> Processing Dependency: libXext.so.6 for package: libXrandr-1.3.1-2.fc15.i686
              ---> Package libXrender.i686 0:0.9.6-2.fc15 will be installed
              ---> Package libstdc++.i686 0:4.6.0-9.fc15 will be installed
              --> Processing Dependency: libgcc_s.so.1(GCC_3.3) for package: libstdc++-4.6.0-9.fc15.i686
              --> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: libstdc++-4.6.0-9.fc15.i686
              --> Processing Dependency: libgcc_s.so.1(GCC_4.2.0) for package: libstdc++-4.6.0-9.fc15.i686
              --> Processing Dependency: libgcc_s.so.1 for package: libstdc++-4.6.0-9.fc15.i686
              --> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: libstdc++-4.6.0-9.fc15.i686
              --> Processing Dependency: libgcc_s.so.1(GCC_3.3.1) for package: libstdc++-4.6.0-9.fc15.i686
              ---> Package ncurses-devel.i686 0:5.8-2.20110319.fc15 will be installed
              --> Processing Dependency: libmenu.so.5 for package: ncurses-devel-5.8-2.20110319.fc15.i686
              --> Processing Dependency: libmenuw.so.5 for package: ncurses-devel-5.8-2.20110319.fc15.i686
              --> Processing Dependency: libtinfo.so.5 for package: ncurses-devel-5.8-2.20110319.fc15.i686
              --> Processing Dependency: libpanelw.so.5 for package: ncurses-devel-5.8-2.20110319.fc15.i686
              --> Processing Dependency: libpanel.so.5 for package: ncurses-devel-5.8-2.20110319.fc15.i686
              --> Processing Dependency: libformw.so.5 for package: ncurses-devel-5.8-2.20110319.fc15.i686
              --> Processing Dependency: libtic.so.5 for package: ncurses-devel-5.8-2.20110319.fc15.i686
              --> Processing Dependency: libform.so.5 for package: ncurses-devel-5.8-2.20110319.fc15.i686
              ---> Package zlib-devel.i686 0:1.2.5-3.fc15 will be installed
              --> Processing Dependency: libz.so.1 for package: zlib-devel-1.2.5-3.fc15.i686
              --> Running transaction check
              ---> Package glibc-common.x86_64 0:2.13.90-9 will be updated
              --> Processing Dependency: glibc-common = 2.13.90-9 for package: glibc-2.13.90-9.x86_64
              ---> Package glibc-common.x86_64 0:2.14-2 will be an update
              ---> Package glibc-headers.x86_64 0:2.13.90-9 will be updated
              --> Processing Dependency: glibc-headers = 2.13.90-9 for package: glibc-devel-2.13.90-9.x86_64
              ---> Package glibc-headers.x86_64 0:2.14-2 will be an update
              ---> Package libX11.i686 0:1.4.3-1.fc15 will be installed
              --> Processing Dependency: libxcb.so.1 for package: libX11-1.4.3-1.fc15.i686
              ---> Package libXext.i686 0:1.2.0-2.fc15 will be installed
              ---> Package libgcc.x86_64 0:4.6.0-7.fc15 will be updated
              ---> Package libgcc.i686 0:4.6.0-9.fc15 will be installed
              ---> Package libgcc.x86_64 0:4.6.0-9.fc15 will be an update
              ---> Package libxcb-devel.x86_64 0:1.7-2.fc15 will be installed
              --> Processing Dependency: pkgconfig(xau) >= 0.99.2 for package: libxcb-devel-1.7-2.fc15.x86_64
              ---> Package ncurses-libs.i686 0:5.8-2.20110319.fc15 will be installed
              ---> Package nss-softokn-freebl.i686 0:3.12.10-1.fc15 will be installed
              ---> Package xorg-x11-proto-devel.noarch 0:7.6-8.fc15 will be installed
              ---> Package zlib.i686 0:1.2.5-3.fc15 will be installed
              --> Running transaction check
              ---> Package glibc.x86_64 0:2.13.90-9 will be updated
              ---> Package glibc.x86_64 0:2.14-2 will be an update
              ---> Package glibc-devel.x86_64 0:2.13.90-9 will be updated
              ---> Package glibc-devel.x86_64 0:2.14-2 will be an update
              ---> Package libXau-devel.x86_64 0:1.0.6-2.fc15 will be installed
              ---> Package libxcb.i686 0:1.7-2.fc15 will be installed
              --> Processing Dependency: libXau.so.6 for package: libxcb-1.7-2.fc15.i686
              --> Running transaction check
              ---> Package libXau.i686 0:1.0.6-2.fc15 will be installed
              --> Finished Dependency Resolution
              Error: Protected multilib versions: libstdc++-4.6.0-9.fc15.i686 != libstdc++-4.6.0-7.fc15.x86_64
              You could try using --skip-broken to work around the problem
              You could try running: rpm -Va --nofiles --nodigest

              how can I change the Android SDK location path?

              Reply
              • Your /opt/android-sdk/tools directory looks good.

                Do you have enabled Fedora 15 Updates repository?

                You could change Android SDK location path here:

                Reply
                • I guess is enable but Im not complety sure, How can I check it?

                  Reply
                  • Simply list repos:

                    
                    yum repolist
                    
                    Reply
                    • The emulator is already launched, thanks for all

                      Reply
                      • Good to hear that you got it working! :)

    2. how to ununstall ADT plugin

      Reply
      • Hi sanam,

        You could uninstall it with following method:
        Open Help Menu >> Click About Eclipse SDK >> Click Installation Details >> Select Android stuff >> Click Uninstall…

        Reply
    3. When i add ADT Plugin in eclipse indigos , the problems is comes is shown below .

      Cannot complete the install because one or more required items could not be found.
      Software currently installed: Shared profile 1.0.0.1311331794947 (SharedProfile_epp.package.java 1.0.0.1311331794947)
      Missing requirement: Shared profile 1.0.0.1311331794947 (SharedProfile_epp.package.java 1.0.0.1311331794947) requires ‘org.maven.ide.eclipse [1.0.0.20110607-2117]’ but it could not be found.

      i have found this error also in ubuntu-10.10 and ubuntu-10.04-LTS ,

      can any one have the solution if this proble ,

      please send me a mail on [email protected] ,

      Thank You to ALL.

      Reply
      • Hi Rahul,

        This sounds some problem with permissions on your system and I think this error is not only related to ADT plugin? What happens if you try do installation as root?

        Reply
    4. hi ,

      when i try to do this :
      yum install glibc.i686 glibc-devel.i686 libstdc++.i686 zlib-devel.i686 ncurses-devel.i686 libX11-devel.i686 libXrender.i686 libXrandr.i686

      I get this error:
      No package glibc.i686 available.
      No package glibc-devel.i686 available.
      No package libstdc++.i686 available.
      No package zlib-devel.i686 available.
      No package ncurses-devel.i686 available.
      No package libX11-devel.i686 available.
      No package libXrender.i686 available.
      No package libXrandr.i686 available.
      Error: Nothing to do

      I am using fedora 14

      Reply
      • Hi Basmah,

        Could you post output of following command:

        
        yum repolist
        
        Reply
    5. Help me !

      I have tried to install SDK during 3 days, but it always shows :

      Failed to start emulator: Cannot run program “/opt/android-sdk//tools/emulator”: error=13, Permission denied

      ????

      Thank you very much!

      Reply
    6. Oh, i succeed ! But, SDK don’t show when i start ! Help me !

      Reply
      • emulator: emulator window was out of view and was recentred
        emulator-arm: xcb_io.c:221: poll_for_event: Assertion `(((long) (event_sequence) – (long) (dpy->request)) <= 0)' failed.

        Reply
        • Hi Trung,

          Could you post your commands what you are trying to run?

          Do you got that permission problem fixed?

          Reply
    7. Hi Mate,

      Thanks for such a great post. its fool proof…i cant belive i managed to get all this done..

      cheers for the help

      regards
      h

      Reply
    8. Hi!

      When SDK started, it had showed :

      [2011-08-10 20:57:09 – Evil] New emulator found: emulator-5554
      [2011-08-10 20:57:09 – Evil] Waiting for HOME (‘android.process.acore’) to be launched…
      [2011-08-10 20:59:14 – Evil] HOME is up on device ’emulator-5554′
      [2011-08-10 20:59:14 – Evil] Uploading Evil.apk onto device ’emulator-5554′
      [2011-08-10 20:59:18 – Evil] Installing Evil.apk…
      [2011-08-10 21:01:00 – Evil] Success!
      [2011-08-10 21:01:00 – Evil] Starting activity com.evil.EvilActivity on device emulator-5554
      [2011-08-10 21:01:02 – Evil] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=com.evil/.EvilActivity }
      [2011-08-10 21:03:56 – Emulator] emulator-arm: xcb_io.c:221: poll_for_event: Assertion `(((long) (event_sequence) – (long) (dpy->request)) <= 0)' failed.

      When i was dragging the mouse, it disappeared.

      I can not run !

      Please !

      Reply
      • Hi Trung,

        Are you trying to run emulator? Or where you get this error message?

        Reply
    9. Is it working with JRE7?

      Reply
      • Hi lan,

        I’m currently using Android SDK + ADT on Eclipse 3.7 with JDK 7 and have no problems with it.

        Reply
    10. Failed to start emulator: Cannot run program “/opt/android-sdk//tools/emulator”: java.io.IOException: error=2, No such file or directory

      i get this error
      i tried every possible solution but nothing seems to work out
      please help ..

      Reply
    11. please tell how to edit /etc/profile file ..

      Reply
    12. Use Eclipse Indigo to avoid errors.

      Reply
    13. Salvou minha vida, ja tinha instalao o centos 6 mais nada fazia o sdk do android funcionar direito!. Parabéns pelo post! Obrigado!

      Reply
    14. # For SDK version r_08 and higher, also add this for adb:
      PATH=$PATH:/opt/android-sdk/platform-tools
      export PATH

      Reply
      • Hi Mitsklas,

        Thanks! Added to guide too. :)

        Reply
1 2 3 4

Leave a Reply to Namrata Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close