Install Adobe Reader on Fedora 28/27, CentOS/RHEL 7.5/6.9 - Comment Page: 7

This is guide shows, howto install Adobe Reader (Acrobat PDF Reader) current version 9.5.5 RPM on Fedora 28/27, CentOS 7.5/6.9, Red Hat (RHEL) 7.5/6.9. This method works both 32-bit and 64-bit architectures. Note: Before it was possible install Adobe Reader using YUM, but currently there is not Adobe Reader in their 32-bit repo, so here is updated installation guide to get Adobe Reader working. 1. Change Root User sudo -i ## OR ## su - 2. Get Adobe Reader RPM package cd /tmp ## English version ## wget http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i486linux_enu.rpm [inttf_post_ad1] 3a. Install Adobe Reader (acroread)...

196 comments on “Install Adobe Reader on Fedora 28/27, CentOS/RHEL 7.5/6.9 - Comment Page: 7

1 5 6 7 8
    1. Hi,

      I, too, experience the warning

      (acroread:4246): Gtk-WARNING **: Unable to locate theme engine in module_path: “murrine”,

      However, when I try yum check gtk-murrine-engine I just get “Package gtk-murrine-engine-0.98.2-7.el7.x86_64 already installed and latest version: Nothing to do”, so the package is installed and available.

      Additionally, as soon as I open the print dialouge or the preferences window acroread crashes without giving me any error code.

      Reply
      • I am very sorry, I forgot to mention that I am running Centos 7.2.1511.

        Reply
        • Hello Heydenreich,

          I have to recheck this guide on CentOS 7.

          Reply
        • I installed Acrobat on CentOS 7 and updated this guide. I used default CentOS 7 desktop with adwaita theme and gtk-murrine-engine is not needed, but if you need it, then install 32-bit version and try again, like:

          
          yum install gtk-murrine-engine.i686
          
          Reply
          • Thanks for your help! Unfortunately, yum does not find the gtk-murrine-engine for i686. The system installed the x86_64 but can not find anything else. In which repository should this version be part of?

            Reply
            • nux-dextop repo:

              
              yum list available |grep murrine
              gtk-murrine-engine.i686                  0.98.2-4.el7                 nux-dextop
              gtk-murrine-engine.x86_64                0.98.2-7.el7                 epel      
              gtk-murrine-engine-debuginfo.i686        0.98.2-4.el7                 nux-dextop
              

              Should be installed / enabled on step 3b.?

              Reply
              • My excuses for replying so late, but the problem at this point is, that the x86 version of the gtk-murrine-engine is already installed on the system, and if I try to install the i686 version I get a ‘multilib version problems found’ error message:

                Protected multilib versions: gtk-murrine-engine-0.98.2-4.el7.i686 != gtk-murrine-engine-0.98.2-7.el7.x86_64

                If I install it anyways, the MATE desktop for CentOS 7 will no longer work properly, as most graphic features of windows etc. can’t be displayed properly anymore.

                Reply
    2. I tried to install Adobe Reader on my Laptop having CENTOS 7, but couldn’y able to do that. During installation I find following errors
      [email protected] tmp]# yum localinstall http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release-0-5.el7.nux.noarch.rpm
      Loaded plugins: fastestmirror, langpacks
      nux-dextop-release-0-5.el7.nux.noarch.rpm | 9.7 kB 00:00
      Examining /var/tmp/yum-root-yWUR9g/nux-dextop-release-0-5.el7.nux.noarch.rpm: nux-dextop-release-0-5.el7.nux.noarch
      /var/tmp/yum-root-yWUR9g/nux-dextop-release-0-5.el7.nux.noarch.rpm: does not update installed package.
      Nothing to do
      Please anybody help me

      Reply
      • Hi Soumik,

        Looks like that you have nux-dextop already installed?

        Reply
    3. Hello:
      could you post how to get “make xconfig” and other kernel build to work on Fedora 24, using Qt 5.x (Installed by default on /opt/Qt ) ?
      Thanks a lot.

      Reply
    4. Anybody got this working on RHEL/CENTOS 7.3? It worked for me in 7.2, but after upgrade acroread segfaults.

      Reply
    5. /opt/Adobe/Reader9/Reader/intellinux/bin/acroread: error while loading shared libraries: libmount.so.1: cannot open shared object file: No such file or directory

      any ideas please

      Bob

      Reply
      • Hi bob,

        Try simply:

        
        dnf install libmount.i686 libmount.x86_64
        
        ## OR ##
        
        yum install libmount.i686 libmount.x86_64
        
        Reply
        • Hi,
          Thanks for the reply.
          I managed to get a clean install with no errors however when I click the icon nothing happens. Also at command line acroread does nothing
          Any ideas please.
          Regards Bob

          Reply
    6. I believe there are some architecture issues on Fedora 25.
      Following this guide, acroread won’t launch, and I get no error messages. When I run `strace acroread`, I see a bunch of error messages about missing files in lib directories, eg /usr/lib/tls/i686/libnss_sss.so.2. I have no such file or directory, and the libsss_nss package I have installed is for 64 bit.
      I understand dnf reads the dependencies from the downloaded rpm file and installs them automatically. However, this seems to install the 64-bit versions, and it seems the package needs a lot of 32-bit versions.
      Now, my first installation of the package installed some 100 packages, so I’m no longer sure what packages that were installed, and I’m not sure what packages need to be 32-bit.

      Any ideas on this?

      Reply
      • dnf install sssd-client.i686
        dnf install nss_nis-2.24-4.fc25.i686

        Reply
    7. This procedure was intended to work for Fedora 26… and Does NOT.
      Could you please update it for Fedora 26 ?

      Because Acroread has yet no good equivalent for “Advanced Search” !
      Hopefully one day, otherwise excellent, Linux “Okular” makes some progress there.

      Thanks for the attention.

      Andre

      Reply
      • Hi Andre,

        Yes, you are right this doesn’t work on Fedora 26. I was just testing this, but still inspecting strace output to figure out why this not work anymore. Quick fix is install CentOS 7 virtual machine and use Adobe Reader with it.

        Reply
    8. yum localinstall AdbeRdr9.5.5-1_i486linux_enu.rpm libcanberra-gtk2.i686 adwaita-gtk2-theme.i686 PackageKit-gtk3-module.i686

      I get:
      [[email protected] ron]# yum localinstall AdbeRdr9.5.5-1_i486linux_enu.rpm libcanberra-gtk2.i686 adwaita-gtk2-theme.i686.rpm PackageKit-gtk3-module.i686.rpm
      Loaded plugins: fastestmirror, langpacks
      Cannot open: AdbeRdr9.5.5-1_i486linux_enu.rpm. Skipping.
      Skipping: libcanberra-gtk2.i686, filename does not end in .rpm.
      Cannot open: adwaita-gtk2-theme.i686.rpm. Skipping.
      Cannot open: PackageKit-gtk3-module.i686.rpm. Skipping.
      Nothing to do
      [[email protected] ron]#

      centos 7.3 latest

      Reply
    9. I installed the adobe acrobat rpm on my fedora 25 which promptly led to errors throughout the system and a failure to boot. Had to re-install, but I got to reuse my home directory. Won’t repeat

      Reply
    10. Thank you for this site. It singlehandedly saved me from disaster after getting a new laptop with a network card that doesn’t seem to be supported by most of the Linux distros. I have been running Slackware for 15 years and this is the first time I have had hardware new enough not to work. And I was looking for a distro where I can spend less time on playing home sysadmin.

      Your nVidia driver and this post on Acroread are just wonderful. I can’t thank you enough.

      In checking the dependencies you recommended, I was alarmed to see some wayland packages. As you know Wayland + nVidia = Fedora crisis. So I didn’t install the dependencies… and acroread still works ok so far.

      Thank you. Thank you!

      Bill

      Reply
    11. And how to uninstall or remove it ?
      Thanks,
      Jay

      Reply
1 5 6 7 8

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close