Install Apache/PHP 7.2.5 on Fedora 28/27, CentOS/RHEL 7.5/6.9 - Comment Page: 6

This guide shows howto install Apache HTTP Server (httpd) with PHP 7.2.5 and following modules on Fedora 28/27/26, CentOS 7.5/6.9 and Red Hat (RHEL) 7.5/6.9 systems. OPcache (php-opcache) - The Zend OPcache provides faster PHP execution through opcode caching and optimization. APCu (php-pecl-apcu) - APCu userland caching CLI (php-cli) - Command-line interface for PHP PEAR (php-pear) - PHP Extension and Application Repository framework PDO (php-pdo) - A database access abstraction module for PHP applications MySQL (php-mysqlnd) - A module for PHP applications that use MySQL databases PostgreSQL (php-pgsql) - A PostgreSQL database module for PHP MongoDB...

264 comments on “Install Apache/PHP 7.2.5 on Fedora 28/27, CentOS/RHEL 7.5/6.9 - Comment Page: 6

1 4 5 6 7 8
    1. It worked like a charm! :D Thank you VERY much!

      Now, i will follow your website :)

      Bye from
      Portugal

      Reply
    2. Hi

      I need to install php-devel

      I run the command: sudo yum search –disablerepo=* –enablerepo=remi,remi.php55, remi-test php-devel
      that found “php-devel.x86_64 : Files needed for building PHP extension”. BUT, when i try to install, i get this error:

      sudo yum install php-devel.x86_64
      Loaded plugins: fastestmirror, refresh-packagekit, security
      Loading mirror speeds from cached hostfile
      * base: mirror.trueinter.net
      * epel: ftp.fau.de
      * extras: mirror.trueinter.net
      * updates: mirror.trueinter.net
      * webtatic: us-east.repo.webtatic.com
      Setting up Install Process
      Resolving Dependencies
      --> Running transaction check
      ---> Package php-devel.x86_64 0:5.3.3-27.el6_5 will be installed
      --> Processing Dependency: php(x86-64) = 5.3.3-27.el6_5 for package: php-devel-5.3.3-27.el6_5.x86_64
      --> Processing Dependency: automake for package: php-devel-5.3.3-27.el6_5.x86_64
      --> Processing Dependency: autoconf for package: php-devel-5.3.3-27.el6_5.x86_64
      --> Running transaction check
      ---> Package autoconf.noarch 0:2.63-5.1.el6 will be installed
      ---> Package automake.noarch 0:1.11.1-4.el6 will be installed
      ---> Package php-devel.x86_64 0:5.3.3-27.el6_5 will be installed
      --> Processing Dependency: php(x86-64) = 5.3.3-27.el6_5 for package: php-devel-5.3.3-27.el6_5.x86_64
      --> Finished Dependency Resolution
      Error: Package: php-devel-5.3.3-27.el6_5.x86_64 (updates)
      Requires: php(x86-64) = 5.3.3-27.el6_5
      Installed: php-5.5.7-1.el6.remi.x86_64 (@remi-php55)
      php(x86-64) = 5.5.7-1.el6.remi
      Available: php-5.3.3-26.el6.x86_64 (base)
      php(x86-64) = 5.3.3-26.el6
      Available: php-5.3.3-27.el6_5.x86_64 (updates)
      php(x86-64) = 5.3.3-27.el6_5
      You could try using --skip-broken to work around the problem
      You could try running: rpm -Va --nofiles --nodigest

      What can i do?

      Reply
      • Hi Richardd,

        Try simply:

        
        yum --enablerepo=remi,remi-php55 install php-devel
        
        Reply
    3. Just for people who can have problem like me – with (re)start httpd service on Fedora 19:

      Job for httpd.service failed. See ‘systemctl status httpd.service’ and ‘journalctl -xn’ for details.
      (…)
      httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.modules.d/10-php…e

      In my case problem was openssl which had to be update by using:

      yum update openssl

      Regards

      Reply
    4. I’m experiencing the same issues as Keys2IT above, CentOS 6.5. I added the remi repository to upgrade PHP from 5.3 to 5.5 and I had to uninstall phpmyadmin and php-mcrypt before it would let me. Then I ran

      yum --enablerepo=remi,remi-php55 update

      and it updated everything. Now I’m trying to reinstall phpmyadmin and php-mcrypt and getting the following…


      # yum --enablerepo=remi,remi-test --disablerepo=epel install php-mcrypt
      Loaded plugins: priorities, refresh-packagekit, security
      Setting up Install Process
      Resolving Dependencies
      --> Running transaction check
      ---> Package php-mcrypt.x86_64 0:5.4.24-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.24-1.el6.remi for package: php-mcrypt-5.4.24-1.el6.remi.x86_64
      --> Finished Dependency Resolution
      Error: Package: php-mcrypt-5.4.24-1.el6.remi.x86_64 (remi)
      Requires: php-common(x86-64) = 5.4.24-1.el6.remi
      Installed: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55)
      php-common(x86-64) = 5.5.8-1.el6.remi
      Available: php-common-5.3.3-26.el6.x86_64 (base)
      php-common(x86-64) = 5.3.3-26.el6
      Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
      php-common(x86-64) = 5.3.3-27.el6_5
      Available: php-common-5.4.23-1.el6.remi.x86_64 (remi)
      php-common(x86-64) = 5.4.23-1.el6.remi
      Available: php-common-5.4.24-1.el6.remi.x86_64 (remi)
      php-common(x86-64) = 5.4.24-1.el6.remi
      You could try using --skip-broken to work around the problem
      You could try running: rpm -Va --nofiles --nodigest

      Here’s the output of “rpm -qa php\*”:


      php-process-5.5.8-1.el6.remi.x86_64
      php-ldap-5.5.8-1.el6.remi.x86_64
      php-common-5.5.8-1.el6.remi.x86_64
      php-devel-5.5.8-1.el6.remi.x86_64
      php-tidy-5.5.8-1.el6.remi.x86_64
      php-imap-5.5.8-1.el6.remi.x86_64
      php-pecl-jsonc-1.3.3-1.el6.remi.5.5.x86_64
      php-pecl-apc-3.1.15-0.3.svn329913.el6.remi.1.x86_64
      php-cli-5.5.8-1.el6.remi.x86_64
      php-gd-5.5.8-1.el6.remi.x86_64
      php-snmp-5.5.8-1.el6.remi.x86_64
      php-mbstring-5.5.8-1.el6.remi.x86_64
      php-php-gettext-1.0.11-3.el6.noarch
      php-xml-5.5.8-1.el6.remi.x86_64
      php-pdo-5.5.8-1.el6.remi.x86_64
      php-odbc-5.5.8-1.el6.remi.x86_64
      php-soap-5.5.8-1.el6.remi.x86_64
      php-xmlrpc-5.5.8-1.el6.remi.x86_64
      php-pecl-jsonc-devel-1.3.3-1.el6.remi.5.5.x86_64
      php-5.5.8-1.el6.remi.x86_64
      php-pear-1.9.4-23.el6.remi.noarch
      php-mysqlnd-5.5.8-1.el6.remi.x86_64
      php-pecl-zip-1.12.4-1.el6.remi.5.5.x86_64

      Reply
    5. oops, I copied and pasted the wrong command/output… I was trying remi-test then.


      yum --enablerepo=remi,remi-php55 install php-mcrypt
      Loaded plugins: priorities, refresh-packagekit, security
      1146 packages excluded due to repository priority protections
      Setting up Install Process
      Resolving Dependencies
      --> Running transaction check
      ---> Package php-mcrypt.x86_64 0:5.3.3-3.el6 will be installed
      --> Processing Dependency: php(zend-abi) = 20090626 for package: php-mcrypt-5.3.3-3.el6.x86_64
      --> Processing Dependency: php(api) = 20090626 for package: php-mcrypt-5.3.3-3.el6.x86_64
      --> Finished Dependency Resolution
      Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel)
      Requires: php(api) = 20090626
      Installed: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55)
      php(api) = 20121113-64
      Available: php-common-5.3.3-26.el6.x86_64 (base)
      php(api) = 20090626
      Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
      php(api) = 20090626
      Available: php-common-5.4.23-1.el6.remi.x86_64 (remi)
      php(api) = 20100412-x86-64
      Available: php-common-5.4.24-1.el6.remi.x86_64 (remi)
      php(api) = 20100412-x86-64
      Available: php-common-5.5.7-1.el6.remi.x86_64 (remi-php55)
      php(api) = 20121113-64
      Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel)
      Requires: php(zend-abi) = 20090626
      Installed: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55)
      php(zend-abi) = 20121212-64
      Available: php-common-5.3.3-26.el6.x86_64 (base)
      php(zend-abi) = 20090626
      Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
      php(zend-abi) = 20090626
      Available: php-common-5.4.23-1.el6.remi.x86_64 (remi)
      php(zend-abi) = 20100525-x86-64
      Available: php-common-5.4.24-1.el6.remi.x86_64 (remi)
      php(zend-abi) = 20100525-x86-64
      Available: php-common-5.5.7-1.el6.remi.x86_64 (remi-php55)
      php(zend-abi) = 20121212-64
      You could try using --skip-broken to work around the problem
      You could try running: rpm -Va --nofiles --nodigest

      Reply
    6. Installed as described but startup-service was not in folder /etc/init.d/
      So something went wrong during installation on fedora 20


      [email protected]:47:50 /etc/init.d (12)
      $ ls -la
      total 112
      drwxr-xr-x. 2 root root 4096 Feb 14 17:08 .
      drwxr-xr-x. 10 root root 4096 Jan 14 14:08 ..
      -rwxrwxrwx. 1 root root 117 Feb 13 14:33 dovecot
      -rw-r--r--. 1 root root 13430 Jan 14 13:34 functions
      -rwxr-xr-x. 1 root root 6928 Dec 12 01:49 livesys
      -rwxr-xr-x. 1 root root 6928 Feb 14 17:08 #livesys#
      -rwxr-xr-x. 1 root root 1054 Dec 12 01:48 livesys-late
      -rwxr-xr-x. 1 root root 2989 Jan 14 13:34 netconsole
      -rwxr-xr-x. 1 root root 6754 Jan 14 13:34 network
      -rw-r--r--. 1 root root 1160 Dec 5 23:22 README
      -rwxr-xr-x. 1 root root 6796 Dec 18 20:16 vboxautostart-service
      -rwxr-xr-x. 1 root root 10140 Dec 18 20:16 vboxballoonctrl-service
      -rwxr-xr-x. 1 root root 12679 Dec 18 20:16 vboxdrv
      -rwxr-xr-x. 1 root root 9917 Dec 18 20:16 vboxweb-service

      [email protected]:48:02 /etc/init.d (12)
      $ yum --enablerepo=remi install httpd php php-common
      Loaded plugins: langpacks, refresh-packagekit
      Package httpd-2.4.6-6.fc20.x86_64 already installed and latest version
      Package php-5.5.9-1.fc20.remi.x86_64 already installed and latest version
      Package php-common-5.5.9-1.fc20.remi.x86_64 already installed and latest version
      Nothing to do

      I had one error during installation


      [email protected]:33:48 ~/git/hub/emacs/org (7)
      $ sudo rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
      Retrieving http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
      warning: /var/tmp/rpm-tmp.7y2LiK: Header V3 RSA/SHA256 Signature, key ID 172ff33d: NOKEY
      Preparing... ################################# [100%]
      Updating / installing...
      1:rpmfusion-free-release-19-1 ################################# [100%]
      [email protected]:33:55 ~/git/hub/emacs/org (7)
      $ sudo rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
      Retrieving http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
      warning: /var/tmp/rpm-tmp.ehnP85: Header V3 RSA/SHA256 Signature, key ID cd30c86b: NOKEY
      Preparing... ################################# [100%]
      Updating / installing...
      1:rpmfusion-nonfree-release-19-1 ################################# [100%]
      [email protected]:34:06 ~/git/hub/emacs/org (7)
      $ sudo -i
      [email protected]:34:37 ~ (3)
      $ rpm -Uvh http://rpms.famillecollet.com/remi-release-20.rpm
      Retrieving http://rpms.famillecollet.com/remi-release-20.rpm
      warning: /var/tmp/rpm-tmp.tqwwI9: Header V3 DSA/SHA1 Signature, key ID 00f97f56: NOKEY
      Preparing... ################################# [100%]
      Updating / installing...
      1:remi-release-20-1.fc20.remi ################################# [100%]
      [email protected]:35:37 ~ (3)
      $ yum --enablerepo=remi install httpd php php-common
      Loaded plugins: langpacks, refresh-packagekit
      google-chrome | 951 B 00:00
      remi | 2.9 kB 00:00
      rpmfusion-free | 3.3 kB 00:00
      rpmfusion-free-updates | 3.3 kB 00:00
      rpmfusion-nonfree | 3.3 kB 00:00
      rpmfusion-nonfree-updates | 3.3 kB 00:00
      russianfedora-free | 3.6 kB 00:00
      russianfedora-free-updates | 3.6 kB 00:00
      russianfedora-nonfree | 3.6 kB 00:00
      russianfedora-nonfree-updates | 3.6 kB 00:00
      updates/20/x86_64/metalink | 30 kB 00:00
      updates | 4.6 kB 00:00
      virtualbox | 951 B 00:00
      (1/2): remi/20/primary_db | 349 kB 00:00
      (2/2): updates/20/x86_64/primary_db | 7.8 MB 00:07
      (1/11): rpmfusion-free/20/x86_64/group_gz | 1.6 kB 00:00
      (2/11): google-chrome/primary | 1.9 kB 00:00
      (3/11): rpmfusion-free-updates/20/x86_64/group_gz | 1.6 kB 00:00
      (4/11): rpmfusion-nonfree/20/x86_64/group_gz | 1.0 kB 00:00
      (5/11): rpmfusion-nonfree-updates/20/x86_64/group_gz | 1.0 kB 00:00
      (6/11): rpmfusion-nonfree/20/x86_64/primary_db | 137 kB 00:00
      (7/11): rpmfusion-nonfree-updates/20/x86_64/primary_db | 51 kB 00:00
      (8/11): rpmfusion-free-updates/20/x86_64/primary_db | 150 kB 00:00
      (9/11): rpmfusion-free/20/x86_64/primary_db | 445 kB 00:01
      (10/11): updates/20/x86_64/updateinfo | 740 kB 00:01
      (11/11): updates/20/x86_64/pkgtags | 961 kB 00:01
      google-chrome 3/3
      Resolving Dependencies
      --> Running transaction check
      ---> Package httpd.x86_64 0:2.4.6-6.fc20 will be installed
      --> Processing Dependency: httpd-tools = 2.4.6-6.fc20 for package: httpd-2.4.6-6.fc20.x86_64
      error: rpmdbNextIterator: skipping h# 1546 region trailer: BAD, tag 1314205516 type 1768846712 offset -540159542 count 775107116

      error: rpmdbNextIterator: skipping h# 1546 region trailer: BAD, tag 1314205516 type 1768846712 offset -540159542 count 775107116
      --> Processing Dependency: fedora-logos-httpd for package: httpd-2.4.6-6.fc20.x86_64

      And for db-packages another one


      ---> Package postgresql-libs.x86_64 0:9.3.2-2.fc20 will be installed
      --> Finished Dependency Resolution
      error: rpmdbNextIterator: skipping h# 1546 region trailer: BAD, tag 1314205516 type 1768846712 offset -540159542 count 775107116

      Dependencies Resolved

      ================================================================================

      Has anybody an idea what I did wrong?

      Reply
      • Hi Christian Hofer,

        Fedora 20 doesn’t use anymore init.d scripts, you can use the another command:

        
        service httpd start
        
        ## or you can also use ##
        systemctl start httpd.service
        

        And about yum errors, looks like your rpmdb is corrupted some reason, you could try rebuild it using following command(s):

        
        yum update rpm
        
        rpmdb --rebuilddb
        
        Reply
    7. Can I use the php56?

      yum --enablerepo=remi,remi-php56 install httpd php php-common

      Reply
      • Hi Eduardo,

        Yes you can, but PHP 5.6 is currently alpha version and only for testing, not for production use. First beta maybe appear later this month and stable release maybe June.

        Reply
    8. Hi everybody !

      I have some issues on my actual setup.
      I can not install phpmyadmin as decribe.

      My setup :

      # cat /etc/redhat-release
      CentOS release 6.5 (Final)

      # php -v
      PHP 5.5.10 (cli) (built: Mar 11 2014 17:37:46)
      Copyright (c) 1997-2014 The PHP Group

      # mysql -V
      mysql Ver 14.14 Distrib 5.5.36, for Linux (x86_64) using readline 5.1

      If someone can help ?


      # yum --enablerepo=remi,remi-test install phpmyadmin
      Loaded plugins: fastestmirror, presto
      Loading mirror speeds from cached hostfile
      ^[[A * epel: be.mirror.eurid.eu
      * remi: fr2.rpmfind.net
      * remi-test: fr2.rpmfind.net
      * webtatic: nl.repo.webtatic.com
      Setting up Install Process
      Resolving Dependencies
      --> Running transaction check
      ---> Package phpMyAdmin.noarch 0:4.1.12-1.el6.remi will be installed
      --> Processing Dependency: php-tidy for package: phpMyAdmin-4.1.12-1.el6.remi.noarch
      --> Processing Dependency: php-tcpdf-dejavu-sans-fonts for package: phpMyAdmin-4.1.12-1.el6.remi.noarch
      --> Processing Dependency: php-tcpdf for package: phpMyAdmin-4.1.12-1.el6.remi.noarch
      --> Processing Dependency: php-recode for package: phpMyAdmin-4.1.12-1.el6.remi.noarch
      --> Processing Dependency: php-gmp for package: phpMyAdmin-4.1.12-1.el6.remi.noarch
      --> Processing Dependency: php-bcmath for package: phpMyAdmin-4.1.12-1.el6.remi.noarch
      --> Running transaction check
      ---> Package php-bcmath.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-bcmath-5.4.26-1.el6.remi.x86_64
      ---> Package php-recode.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-recode-5.4.26-1.el6.remi.x86_64
      --> Processing Dependency: librecode.so.0()(64bit) for package: php-recode-5.4.26-1.el6.remi.x86_64
      ---> Package php-tcpdf.noarch 0:6.0.061-1.el6.remi will be installed
      ---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.0.061-1.el6.remi will be installed
      --> Processing Dependency: dejavu-sans-fonts for package: php-tcpdf-dejavu-sans-fonts-6.0.061-1.el6.remi.noarch
      ---> Package php-tidy.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-tidy-5.4.26-1.el6.remi.x86_64
      --> Processing Dependency: libtidy-0.99.so.0()(64bit) for package: php-tidy-5.4.26-1.el6.remi.x86_64
      ---> Package php55w-common.x86_64 0:5.5.9-1.w6 will be installed
      --> Running transaction check
      ---> Package dejavu-sans-fonts.noarch 0:2.30-2.el6 will be installed
      --> Processing Dependency: dejavu-fonts-common = 2.30-2.el6 for package: dejavu-sans-fonts-2.30-2.el6.noarch
      ---> Package libtidy.x86_64 0:0.99.0-19.20070615.1.el6 will be installed
      ---> Package php-bcmath.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-bcmath-5.4.26-1.el6.remi.x86_64
      ---> Package php-recode.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-recode-5.4.26-1.el6.remi.x86_64
      ---> Package php-tidy.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-tidy-5.4.26-1.el6.remi.x86_64
      ---> Package recode.x86_64 0:3.6-28.1.el6 will be installed
      --> Running transaction check
      ---> Package dejavu-fonts-common.noarch 0:2.30-2.el6 will be installed
      --> Processing Dependency: fontpackages-filesystem for package: dejavu-fonts-common-2.30-2.el6.noarch
      ---> Package php-bcmath.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-bcmath-5.4.26-1.el6.remi.x86_64
      ---> Package php-recode.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-recode-5.4.26-1.el6.remi.x86_64
      ---> Package php-tidy.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-tidy-5.4.26-1.el6.remi.x86_64
      --> Running transaction check
      ---> Package fontpackages-filesystem.noarch 0:1.41-1.1.el6 will be installed
      ---> Package php-bcmath.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-bcmath-5.4.26-1.el6.remi.x86_64
      ---> Package php-recode.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-recode-5.4.26-1.el6.remi.x86_64
      ---> Package php-tidy.x86_64 0:5.4.26-1.el6.remi will be installed
      --> Processing Dependency: php-common(x86-64) = 5.4.26-1.el6.remi for package: php-tidy-5.4.26-1.el6.remi.x86_64
      --> Finished Dependency Resolution
      Error: Package: php-bcmath-5.4.26-1.el6.remi.x86_64 (remi)
      Requires: php-common(x86-64) = 5.4.26-1.el6.remi
      Installed: php-common-5.5.10-1.el6.remi.1.x86_64 (@remi-php55)
      php-common(x86-64) = 5.5.10-1.el6.remi.1
      Available: php-common-5.3.3-26.el6.x86_64 (base)
      php-common(x86-64) = 5.3.3-26.el6
      Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
      php-common(x86-64) = 5.3.3-27.el6_5
      Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
      php-common(x86-64) = 5.4.25-2.el6.remi
      Available: php-common-5.4.26-1.el6.remi.x86_64 (remi)
      php-common(x86-64) = 5.4.26-1.el6.remi
      Available: php54w-common-5.4.25-1.w6.x86_64 (webtatic)
      php-common(x86-64) = 5.4.25-1.w6
      Installing: php55w-common-5.5.9-1.w6.x86_64 (webtatic)
      php-common(x86-64) = 5.5.9-1.w6
      Available: php54w-common-5.4.24-1.w6.x86_64 (webtatic)
      Not found
      Available: php55w-common-5.5.8-1.w6.x86_64 (webtatic)
      Not found
      Error: Package: php-tidy-5.4.26-1.el6.remi.x86_64 (remi)
      Requires: php-common(x86-64) = 5.4.26-1.el6.remi
      Installed: php-common-5.5.10-1.el6.remi.1.x86_64 (@remi-php55)
      php-common(x86-64) = 5.5.10-1.el6.remi.1
      Available: php-common-5.3.3-26.el6.x86_64 (base)
      php-common(x86-64) = 5.3.3-26.el6
      Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
      php-common(x86-64) = 5.3.3-27.el6_5
      Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
      php-common(x86-64) = 5.4.25-2.el6.remi
      Available: php-common-5.4.26-1.el6.remi.x86_64 (remi)
      php-common(x86-64) = 5.4.26-1.el6.remi
      Available: php54w-common-5.4.25-1.w6.x86_64 (webtatic)
      php-common(x86-64) = 5.4.25-1.w6
      Installing: php55w-common-5.5.9-1.w6.x86_64 (webtatic)
      php-common(x86-64) = 5.5.9-1.w6
      Available: php54w-common-5.4.24-1.w6.x86_64 (webtatic)
      Not found
      Available: php55w-common-5.5.8-1.w6.x86_64 (webtatic)
      Not found
      Error: Package: php-recode-5.4.26-1.el6.remi.x86_64 (remi)
      Requires: php-common(x86-64) = 5.4.26-1.el6.remi
      Installed: php-common-5.5.10-1.el6.remi.1.x86_64 (@remi-php55)
      php-common(x86-64) = 5.5.10-1.el6.remi.1
      Available: php-common-5.3.3-26.el6.x86_64 (base)
      php-common(x86-64) = 5.3.3-26.el6
      Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
      php-common(x86-64) = 5.3.3-27.el6_5
      Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
      php-common(x86-64) = 5.4.25-2.el6.remi
      Available: php-common-5.4.26-1.el6.remi.x86_64 (remi)
      php-common(x86-64) = 5.4.26-1.el6.remi
      Available: php54w-common-5.4.25-1.w6.x86_64 (webtatic)
      php-common(x86-64) = 5.4.25-1.w6
      Installing: php55w-common-5.5.9-1.w6.x86_64 (webtatic)
      php-common(x86-64) = 5.5.9-1.w6
      Available: php54w-common-5.4.24-1.w6.x86_64 (webtatic)
      Not found
      Available: php55w-common-5.5.8-1.w6.x86_64 (webtatic)
      Not found

      Merci !!

      Reply
      • Hi Said,

        Try following:

        
        yum --enablerepo=remi,remi-php55,remi-test install phpmyadmin
        
        Reply
    9. Hi,
      When I run the command ‘service iptable restart’ returns with an error:
      Failed to issue method call: Unit iptable.service failed to load: No such file or directory.

      Reply
    10. thank you very much, it has been very useful

      Reply
    11. Worked perfectly on CentOS 6.5 x86_64.

      Thanks for the great tutorial.

      Reply
    12. thanks! this really helps me a lot! cheers!

      Reply
    13. When I followed the above directions, it installed php 5.1.12, which was a downgrade from the 5.3.3 that I already had installed. Took me an hour to get back to my old version.

      Reply
      • Hi Rich,

        Sorry for the late reply, but this sounds totally unbelievable. Could you post output of following commands:

        
        uname -a
        
        yum repolist
        

        Then it would be nice to know, where you get 5.1.12. I think that there is not any repo nowadays where you could find PHP 5.1.12, remi repo’s current version is 5.5.13.

        Reply
    14. Sorry it seems unbelievable, imagine my surprise when I looked and saw the version.

      Since then, I had removed the extra repositories and added the atomic repository, which I have now used to upgrade to 5.4.29.

      That being said, Im afraid my repolist would no longer be helpful for the above matter.

      Reply
      • Hi again Rich,

        Yes, I could imagine your surprise.

        And you are right, repolist isn’t helpful now.

        I you want still install/update to PHP 5.5, then try just epel+remi repositories (assume that you run CentOS or RHEL) and run following command instead “yum update”:

        
        yum --enablerepo=remi,remi-php55 check-update
        
        ## OR ##
        yum --enablerepo=remi,remi-php55 check-update php\*
        

        And you will see only list of updates and if it looks right, then you can run real update.

        Reply
      • Hi Varun,

        Easiest way to do this is add following line to another pc /etc/hosts file:

        
        10.0.0.122 wordpress
        

        Then you can access it also from another pc using http://wordpress

        If you want use http://ip.ad.dr.ess/wordpress then you have to add that ip on your virtual host file and do some url rewriting. If you have your wordpress installation on separated directory /wordpress, then just add ip to your virtual host (restart server) and it should work.

        Reply
1 4 5 6 7 8

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close