Install Google Chrome on Fedora 32/31, CentOS/RHEL 8/7.7 - Comment Page: 9

This guide explains howto install Google Chrome Web browser on Fedora 32/31/30/29 and CentOS/Red Hat (RHEL) 8.0/7.7. Best way to install and keep up-to-date with Google Chrome browser is use Google's own YUM/DNF repository. Install Google Chrome on Fedora 32/31/30/29, CentOS 8/7.7, Red Hat (RHEL) 8/7.7 [inttf_post_ad1] 1. Change to root user. sudo -i ## OR ## su - 2. Enable Google YUM repository Note: Google Chrome Linux version doesn't get any 32-bit (x86) updates and 32-bit repo is also removed. If you have 32-bit version installed, then you can use it, but you can't get security updates or other updates anymore. Fedora 32/31/30/29 dnf install...

365 comments on “Install Google Chrome on Fedora 32/31, CentOS/RHEL 8/7.7 - Comment Page: 9

1 7 8 9 10 11 13
    1. i downloaded the google chroem and got it installed courtesy JR…on fedora 18… but post installation the authentication key is unable to be retrieved…. kindly help me out of this…tried yum install lsb… but it too dint work….urgent….

      Reply
      • Hi asrar,

        Could you post full error message what you get?

        Reply
    2. cannot install latest chrome release on RHEL6.4.
      Any suggestions?

      google-chrome-stable-28.0.1500.45-205727.x86_64 requires libstdc++.so.6(GLIBCXX_3.4.15)(64bit) : Success – empty transaction

      Reply
    3. Do you have any option to install chrome new version(at least more than 17) in CentOS 5.8. ?
      Details:
      centos-release-5-8.el5 [2.6.18-308.8.1.el5PAE #1 SMP Tue May 29 15:37:08 EDT 2012 i686 i686 i386 GNU/Linux]
      Installed chrome : 14.0.785.0 (Developer Build 87778 Linux)

      Reply
      • Hi smilyface,

        No I haven’t unfortunately. It’s sad, but newer Chrome versions supports only distributions with latest packages.

        Reply
    4. You can change the gpgcheck=0

      Reply
    5. i get this error

      No package google-chrome-stable available.
      Error: Nothing to do

      Reply
      • Hi zezo,

        Could you post output of following commands:

        
        uname -a
        
        yum repolist
        
        cat /etc/yum.repos.d/google-chrome.repo
        
        Reply
    6. [[email protected] ~]# yum install google-chrome-stable

      I am getting below error for my command:

      #########################################
      Loaded plugins: langpacks, refresh-packagekit
      Resolving Dependencies
      –> Running transaction check
      —> Package google-chrome-stable.x86_64 0:31.0.1650.57-1 will be installed
      –> Processing Dependency: lsb >= 4.0 for package: google-chrome-stable-31.0.1650.57-1.x86_64
      –> Processing Dependency: libXss.so.1()(64bit) for package: google-chrome-stable-31.0.1650.57-1.x86_64
      –> Finished Dependency Resolution
      Error: Package: google-chrome-stable-31.0.1650.57-1.x86_64 (google-chrome)
      Requires: libXss.so.1()(64bit)
      Error: Package: google-chrome-stable-31.0.1650.57-1.x86_64 (google-chrome)
      Requires: lsb >= 4.0
      You could try using –skip-broken to work around the problem
      You could try running: rpm -Va –nofiles –nodigest
      [[email protected] ~]#
      #########################################

      Reply
    7. I have installed libXScrnSaver-1.2.2-5.fc19.x86_64.rpm in Fedora 19.
      So ////// Requires: libXss.so.1()(64bit) //////// dependency issue fixed.

      Now I’m getting following error:

      ###########################################
      [[email protected] ~]# yum install google-chrome-stable
      Loaded plugins: langpacks, refresh-packagekit
      Resolving Dependencies
      –> Running transaction check
      —> Package google-chrome-stable.x86_64 0:31.0.1650.57-1 will be installed
      –> Processing Dependency: lsb >= 4.0 for package: google-chrome-stable-31.0.1650.57-1.x86_64
      –> Finished Dependency Resolution
      Error: Package: google-chrome-stable-31.0.1650.57-1.x86_64 (google-chrome)
      Requires: lsb >= 4.0
      You could try using –skip-broken to work around the problem
      You could try running: rpm -Va –nofiles –nodigest
      ###########################################

      Reply
    8. Success.

      To install lsb, I have used below command

      yum install lsb

      Dependency Installed:
      libpng12.x86_64 0:1.2.50-3.fc19 perl-B-Lint.noarch 0:1.17-2.fc19
      perl-CGI.noarch 0:3.63-2.fc19 perl-CPAN.noarch 0:1.9800-264.fc19
      perl-Class-ISA.noarch 0:0.36-1010.fc19 perl-Digest-SHA.x86_64 1:5.84-1.fc19
      perl-ExtUtils-Install.noarch 0:1.58-264.fc19 perl-ExtUtils-MakeMaker.noarch 0:6.64-2.fc19
      perl-ExtUtils-Manifest.noarch 0:1.61-243.fc19 perl-ExtUtils-ParseXS.noarch 1:3.16-264.fc19
      perl-FCGI.x86_64 1:0.74-7.fc19 perl-File-CheckTree.noarch 0:4.42-2.fc19
      perl-HTTP-Tiny.noarch 0:0.017-264.fc19 perl-Locale-Codes.noarch 0:3.26-1.fc19
      perl-Module-Pluggable.noarch 1:4.8-1.fc19 perl-Pod-Checker.noarch 0:1.60-1.fc19
      perl-Pod-LaTeX.noarch 0:0.61-1.fc19 perl-Pod-Parser.noarch 0:1.61-1.fc19
      perl-Pod-Perldoc.noarch 0:3.19.01-1.fc19 perl-Pod-Plainer.noarch 0:1.03-4.fc19
      perl-Pod-Usage.noarch 0:1.61-1.fc19 perl-Sys-Syslog.x86_64 0:0.33-1.fc19
      perl-Test-Simple.noarch 0:0.98-243.fc19 perl-Text-Soundex.x86_64 0:3.04-2.fc19
      perl-Text-Unidecode.noarch 0:0.04-18.fc19 perl-XML-LibXML.x86_64 1:2.0014-2.fc19
      perl-XML-NamespaceSupport.noarch 0:1.11-10.fc19 perl-XML-SAX.noarch 0:0.99-9.fc19
      perl-XML-SAX-Base.noarch 0:1.08-7.fc19 perl-autodie.noarch 0:2.16-1.fc19
      perl-devel.x86_64 4:5.16.3-264.fc19 perl-parent.noarch 1:0.225-243.fc19
      perl-podlators.noarch 0:2.5.1-1.fc19 qt3.x86_64 0:3.3.8b-47.fc19
      redhat-lsb-core.x86_64 0:4.1-14.fc19 redhat-lsb-cxx.x86_64 0:4.1-14.fc19
      redhat-lsb-desktop.x86_64 0:4.1-14.fc19 redhat-lsb-languages.x86_64 0:4.1-14.fc19
      redhat-lsb-printing.x86_64 0:4.1-14.fc19 redhat-lsb-submod-multimedia.x86_64 0:4.1-14.fc19
      redhat-lsb-submod-security.x86_64 0:4.1-14.fc19 spax.x86_64 0:1.5.2-5.fc19
      systemtap-sdt-devel.x86_64 0:2.2.1-1.fc19

      Complete!

      Then i have started to install google chrome.

      yum install google-chrome-stable

      Reply
    9. I do not have google-chrome.repo file in my Fedora 20 server. Can I just install Chrome browser using YUM install chrome ?

      Reply
      • Hi amir,

        First two questions, because I’m not totally sure what you want to do…

        1. Are you sure, that you want install any browser on server?

        2. If you really want/need it, why you don’t just add google-chrome.repo and install google-chrome?

        Reply
    10. thanks, I was able to install google-chrome on the Fedora 20 server. it works!!!

      now back to troubleshooting MySQL on my F20.

      can u upload guides- howto- for MySQL on Fedora? please.

      Reply
    11. Is anyone else experience a complete chrome stable freeze one Feodra 19?

      Just in the last couple of weeks Chrome has gone from working flawlessly to becoming completely unresponsive. I have to force quit it.

      Thanks

      Reply
    12. muchas gracias me sirvio :)

      Reply
    13. while placing repo file it cant be pasted in that folder

      Reply
      • Hi vamshii,

        You have to do it as root user.

        Reply
    14. libXss.so.1 installed as libXScrnSaver-1.2.2-6.fc20.i686

      [[email protected] sfw]# rpm -i google-chrome-stable_current_x86_64.rpm
      warning: google-chrome-stable_current_x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY
      error: Failed dependencies:
      libXss.so.1()(64bit) is needed by google-chrome-stable-35.0.1916.153-1.x86_64

      [[email protected] sfw]# yum install libXss.so.1
      Loaded plugins: langpacks, refresh-packagekit
      Package libXScrnSaver-1.2.2-6.fc20.i686 already installed and latest version
      Nothing to do

      Reply
      • Hi Jorge,

        You are installing 64-bit Google Chrome on 32-bit Fedora, that’s why all dependencies fail. So just select Google Chrome 32-bit version/repo and try to install it again.

        Reply
    15. Hi,

      I tried installing the google chrome but getting the below error.


      ~]# yum install google-chrome-stable
      Loaded plugins: langpacks, product-id, subscription-manager
      Server error attempting a GET to /subscription/ returned status 502
      Resolving Dependencies
      --> Running transaction check
      ---> Package google-chrome-stable.x86_64 0:37.0.2062.94-1 will be installed
      --> Processing Dependency: lsb >= 4.0 for package: google-chrome-stable-37.0.2062.94-1.x86_64
      --> Finished Dependency Resolution
      Error: Package: google-chrome-stable-37.0.2062.94-1.x86_64 (google-chrome)
      Requires: lsb >= 4.0
      You could try using --skip-broken to work around the problem
      You could try running: rpm -Va --nofiles --nodigest

      Please help!

      Reply
      • awnser

        hi kamtoat try “sudo yum install lsb

        Reply
1 7 8 9 10 11 13

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close