VirtualBox 6.1.28 / 6.1.29 on Fedora 35/34/33, CentOS/RHEL 8/7 - Comment Page: 18

Oracle VirtualBox is a powerful x86 and AMD64/Intel64 virtualization product for enterprise as well as home use. VirtualBox is a general-purpose full virtualizer for x86 hardware. Targeted at server, desktop and embedded use, it is now the only professional-quality virtualization solution that is also Open Source Software. Check video guide howto install VirtualBox 6.1.28/6.1.29 on Fedora 35/34/33 using .run installer: Check video guide howto install VirtualBox 6.1.28 on Fedora 34/33 using Oracle's own dnf repo: Watch More Videos and Subscribe to if-not-true-then-false.com Youtube Channel VirtualBox supports a large number of guest operating...

810 comments on “VirtualBox 6.1.28 / 6.1.29 on Fedora 35/34/33, CentOS/RHEL 8/7 - Comment Page: 18

1 16 17 18 19 20 27
    1. I typed
      dnf install VirtualBox-5.0
      And i got
      Last metadata expiration check performed 1:03:52 ago
      .
      No package VirtualBox-5.0 available

      Please help me

      Reply
    2. Hi,
      when entered the step:
      “dnf install binutils gcc make patch libgomp glibc-headers glibc-devel kernel-headers kernel-PAE-devel dkms” as a root on fedora 23, I got:
      “Last metadata expiration check performed 0:32:15 ago on Fri Jan 8 13:00:54 2016.
      Package binutils-2.25-15.fc23.x86_64 is already installed, skipping.
      Package gcc-5.3.1-2.fc23.x86_64 is already installed, skipping.
      Package make-1:4.0-5.1.fc23.x86_64 is already installed, skipping.
      Package patch-2.7.5-2.fc23.x86_64 is already installed, skipping.
      Package libgomp-5.3.1-2.fc23.x86_64 is already installed, skipping.
      Package glibc-headers-2.22-7.fc23.x86_64 is already installed, skipping.
      Package glibc-devel-2.22-7.fc23.x86_64 is already installed, skipping.
      Package kernel-headers-4.2.8-300.fc23.x86_64 is already installed, skipping.
      No package kernel-PAE-devel available.
      Package dkms-2.2.0.3-31.git.7c3e7c5.fc23.noarch is already installed, skipping.
      Error: Unable to find a match.”

      Any ideas how to go around this?
      Best Regards
      Maciej

      Reply
      • Hi Maciej,

        You are using wrong command. No PAE kernel on 64-bit system. Right command is first one:

        
        dnf install binutils gcc make patch libgomp glibc-headers glibc-devel kernel-headers kernel-devel dkms
        
        Reply
        • Thank you JR, everything worked great this time!

          Reply
    3. trying to install on fedora 23 got:
      root@penelope fman]# /usr/lib/virtualbox/vboxdrv.sh setup
      bash: /usr/lib/virtualbox/vboxdrv.sh: No such file or directory

      found nothing searching on google.

      any hint?

      Reply
      • Hi Francisco,

        Could you post output of following commands:

        
        rpm -qa VirtualBox\*
        
        ls /usr/lib/virtualbox/vboxdrv.sh -la
        
        Reply
        • [fman@penelope ~]$ rpm -qa VirtualBox\*
          VirtualBox-5.0.12-1.fc23.x86_64
          VirtualBox-kmodsrc-5.0.12-1.fc23.x86_64
          [fman@penelope ~]$

          The issue is that are some missing files and I can not understand why:

          [fman@penelope ~]$ ls /usr/lib/virtualbox/vboxdrv.sh -la
          ls: cannot access /usr/lib/virtualbox/vboxdrv.sh: No such file or directory

          Best regards

          Reply
          • Problems is that you are not using Oracle’s VirtualBox package. You have installed your packages (VirtualBox and VirtualBox-kmodsrc) some other source than virtualbox.org own repo.

            Could you also post output of following command:

            
            dnf list installed |grep VirtualBox
            
            Reply
            • Here the output
              [root@penelope fman]# dnf list installed |grep VirtualBox
              VirtualBox.x86_64 5.0.12-1.fc23 @rpmfusion-free-updates-testing
              VirtualBox-kmodsrc.x86_64 5.0.12-1.fc23 @rpmfusion-free-updates-testing
              akmod-VirtualBox.x86_64 5.0.12-1.fc23 @rpmfusion-free-updates-testing
              kmod-VirtualBox-4.2.8-300.fc23.x86_64.x86_64

              I though I’ve followed the instructions indicated in this article, but maybe I’ve skip an step.

              thanks for your help

              Reply
              • You are probably running dnf install VirtualBox-5.0.12 like I did first time around. Even though in brackets it suggests .12 is the latest, you still need to enter it just as VirtualBox-5.0

                If you look at the y/N prompt before installing, you will see that the package is 5.0.12

                It’s only the command that is 5.0, other wise it will pull from the rpm repo.

                Hope this helps

                Reply
    4. Hi JR

      thanks for your post. I have been using it, and it has worked as a charm. But now using it for my new machine (new centos kernel) I got an error.:

      My machine.:

      uname -r

      3.10.0-327.4.4.el7.x86_64

      Virtual box version.:

      Tried first with:
      * VirtualBox-5.0-5.0.12_104815_el7-1.x86_64.rpm

      and after with:
      *VirtualBox-5.0-5.0.13_104971_el7-1.x86_64.rpm

      I got the same error.:

      WARNING: The vboxdrv kernel module is not loaded. Either there is no module
      available for the current kernel (3.10.0-327.4.4.el7.x86_64) or it failed to
      load. Please recompile the kernel module and install it by

      sudo /sbin/rcvboxdrv setup

      You will not be able to start VMs until this problem is fixed.

      Naturally I did sudo /sbin/rcvboxdrv setup … But then I got.:

      Stopping VirtualBox kernel modules [ OK ]
      Uninstalling old VirtualBox DKMS kernel modules [ OK ]
      Trying to register the VirtualBox kernel modules using DKMS[ OK ]
      Starting VirtualBox kernel modules [FAILED]

      When start the Virtual box impossible to start any machine …:

      Any guess ?

      all the best, and thanks again for the post …

      Reply
      • Just as a complement … I am using CentOS 7.2

        Reply
        • Hi Miup,

          Just tested this again on CentOS 7.2 and I got it working. I use following command:

          
          /usr/lib/virtualbox/vboxdrv.sh setup
          

          I got following errors on dkms uninstall part using latest kernel:

          Uninstalling old VirtualBox DKMS kernel modulesrmdir: failed to remove '.': Invalid argument
          rmdir: failed to remove '.': Invalid argument
          rmdir: failed to remove '.': Invalid argument
          rmdir: failed to remove '.': Invalid argument
          rmdir: failed to remove '.': Invalid argument
          rmdir: failed to remove '.': Invalid argument
          rmdir: failed to remove '.': Invalid argument
          rmdir: failed to remove '.': Invalid argument
          

          But it builds normally without errors and works normally:

          Reply
          • Hi JR.
            ……….

            Thanks for your replay. It turned out that the “problem” was with the BIOS. I needed to disable the UEFI boot and went to legacy. Not really sure why this fixed the problem. But it worked.

            As a complement, I needed to enable virtualization in the BIOS (intel virtualization) in order to get 64 bits distros for linux and windows at the virtual box. But this is quit well documented everywhere on internet.

            again, really thanks for the replay … I appreciated that.

            Reply
    5. Hi JR, you saved my day!! Thank you so much !! I was hitting hard to make virtualbox work in Fedora 23 [4.2.8-300.fc23.x86_64] and [4.3.3-300.fc23.x86_64] but i couldn’t.
      I’m detailing out the issues i encountered, for the benefit of other users.
      I initially installed virtualbox by ‘dnf install VirtualBox’.
      After installation, i tried to launch virtualbox from shell and i got this error:
      [srx@localhost ~]$ virtualbox
      WARNING: The vboxdrv kernel module is not loaded. Either there is no module
      available for the current kernel (4.2.8-300.fc23.x86_64) or it failed to
      load. Please recompile the kernel module and install it by

      sudo /sbin/rcvboxdrv setup

      You will not be able to start VMs until this problem is fixed.
      Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile

      ———-
      But virtualbox launched. On starting a vm, i got this error msg : VirtualBox Kernel driver not installed (rc=-1908)…

      As i’m not a expert linux user, I tried various options from different forums but i couldn’t get it work.
      Finally I followed your steps exactly, plus one additional step – I HAD TO RESTART AFTER THE FINAL STEP as i was getting an error msg (Qt WARNING: Qt: Session management error… ) on launching virtualbox.
      After the restart, it worked like a charm…. Again thank you so much!!!

      Reply
    6. Thanks your tutorial is very usefull for me on fedora 23.

      Reply
    7. When im trying to open my VirtualSystem on VirtualBox wich is Kali Linux it gives me “Kernel Drive not installed (rc=-1908) and i have disabled secure boot

      Reply
    8. cat /var/log/vbox-install.log
      Uninstalling modules from DKMS
      Attempting to install using DKMS
      Failed to install using DKMS, attempting to install without
      Makefile:185: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR= and run Make again. Pare.

      Reply
    9. sudo /usr/lib/virtualbox/vboxdrv.sh setup
      Stopping VirtualBox kernel modules [ OK ]
      Uninstalling old VirtualBox DKMS kernel modules [ OK ]
      Trying to register the VirtualBox kernel modules using DKMSError! Could not find module source directory.
      Directory: /usr/src/vboxhost-5.0.14 does not exist.
      [FALHOU]
      (Failed, trying without DKMS)
      Recompiling VirtualBox kernel modules [FALHOU]
      (Look at /var/log/vbox-install.log to find out what went wrong)
      ➜ ~ cat /var/log/vbox-install.log
      Uninstalling modules from DKMS
      Attempting to install using DKMS
      Failed to install using DKMS, attempting to install without
      Makefile:185: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR= and run Make again. Pare.

      Reply
      • Hi Aristoteles,

        Could you post also output of following commands:

        
        ls -la /usr/src/kernels
        
        ls -la /usr/src
        
        Reply
        • ➜ ~ ls -la /usr/src/kernels
          total 12
          drwxr-xr-x. 3 root root 4096 Jan 30 23:08 .
          drwxr-xr-x. 4 root root 4096 Jan 31 16:27 ..
          drwxr-xr-x 23 root root 4096 Jan 30 23:08 4.3.3-303.fc23.x86_64

          ➜ ~ ls -la /usr/src
          total 16
          drwxr-xr-x. 4 root root 4096 Jan 31 16:27 .
          drwxr-xr-x. 14 root root 4096 Dez 22 23:53 ..
          drwxr-xr-x. 2 root root 4096 Set 10 05:23 debug
          drwxr-xr-x. 3 root root 4096 Jan 30 23:08 kernels

          Reply
    10. Man You are great. I had 2 issues, I searched whole internet and both solutions I found here. :)

      Reply
    11. How can I install VirtualBox extention pack in fedora 23 ?

      Reply
    12. when I run the command dnf install VirtualBox-5.0,
      I am getting this error message below. Any suggestions what can I do to resolve?

      # dnf install VirtualBox-5.0
      Warning: failed loading ‘/etc/yum.repos.d/virtualbox.repo’, skipping.
      Last metadata expiration check performed 0:02:31 ago on Sat Feb 20 12:04:18 2016.
      No package VirtualBox-5.0 available.
      Error: Unable to find a match.

      when I do dnf update command I get the error message below

      # dnf update
      Warning: failed loading ‘/etc/yum.repos.d/virtualbox.repo’, skipping.
      Last metadata expiration check performed 0:04:27 ago on Sat Feb 20 12:04:18 2016.
      Dependencies resolved.
      ================================================================================
      Package Arch Version Repository Size
      ================================================================================
      Skipping packages with broken dependencies:
      galera x86_64 25.3.12-1.rhel7.el7.centos mariadb 7.7 M

      Transaction Summary
      ================================================================================
      Skip 1 Package

      Nothing to do.
      Complete!

      Reply
      • Hi guru,

        Could you post output of following commands:

        
        uname -a
        
        ls -la /etc/yum.repos.d/virtualbox.repo
        
        cat /etc/yum.repos.d/virtualbox.repo
        
        Reply
        • # uname -a
          linux 4.3.5-300.fc23.x86_64 #1 SMP Mon Feb 1 03:18:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

          #
          ]# ls -la /etc/yum.repos.d/virtualbox.repo
          -rw-r–r– 1 root root 259 Feb 20 12:02 /etc/yum.repos.d/virtualbox.repo
          # cat /etc/yum.repos.d/virtualbox.repo
          #Fedora 23/22/21/20/19/18/17/16/15/14/13/12 users
          wget http://download.virtualbox.org/virtualbox/rpm/fedora/virtualbox.repo

          # CentOS 7.2/6.7/5.11 and Red Hat (RHEL) 7.2/6.7/5.11 users
          #wget http://download.virtualbox.org/virtualbox/rpm/rhel/virtualbox.repo

          Reply
        • I also forgot to mention that I have older version of virtual box installed on my server. I don’t know how to remove it. Sorry, It is my fault for not letting you know. my apologies.

          Reply
        • Hi guru,

          You have wrong content on your /etc/yum.repos.d/virtualbox.repo file. You should download file using wget, not copy that command to file, so run following commands (as root on terminal):

          
          cd /etc/yum.repos.d
          
          rm -f virtualbox.repo
          
          wget http://download.virtualbox.org/virtualbox/rpm/fedora/virtualbox.repo
          

          Then repo file content should look same as this http://download.virtualbox.org/virtualbox/rpm/fedora/virtualbox.repo

          Then install works, but maybe it’s better remove older version first. Could you post output of following command:

          
          rpm -qa |grep -i virtual
          
          Reply
          • rpm -qa |grep -i virtual
            VirtualBox-4.3-4.3.36_105129_fedora22-1.x86_64

            Reply
            • To remove old VirtualBox installation run:

              
              dnf remove VirtualBox-4.3
              
              Reply
    13. getting this error when i install VirtualBox-5.0-5.0.14_105127_fedora22-1.x86_64 in fedora 23.

      Failed to open a session for the virtual machine bosh-lite_default_1457003736418_77705.

      VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED).

      Result Code: NS_ERROR_FAILURE (0x80004005)
      Component: ConsoleWrap
      Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

      Please help on this

      Reply
      • Hi lm,

        Go to BIOS/UEFI and enable VT-x.

        Reply
    14. i can fix the kernel issue please help been trying for a month.everything seems update yet still vboxdr aint loading..tried all help online nothing so gonna now…..
      fedora 23….86…4.4.3 and 5.0.14

      Reply
      • Hi nik,

        Could you check your /var/log/vbox-install.log do you see any errors?

        Reply
        • He JR thank you for answering !

          there is nothing in /var/log/ (no)vbox-install.log

          and if i start virtualbox from terminal get the same vboxdrv not loaded if i start it from applications it loads fine but then i get rcv=-1908 kernel nonsence

          Reply
        • also

          [RBN@new-host-4 log]$ dnf repolist
          Fedora 23 – x86_64 5.9 MB/s | 43 MB 00:07
          Importing GPG key 0x98AB5139:
          Userid : “Oracle Corporation (VirtualBox archive signing key) ”
          Fingerprint: 7B0F AB3A 13B9 0743 5925 D9C9 5442 2A4B 98AB 5139
          From : https://www.virtualbox.org/download/oracle_vbox.asc
          Is this ok [y/N]: y
          Fedora 23 – x86_64 – VirtualBox 747 kB/s | 61 kB 00:00
          RPM Fusion for Fedora 23 – Free – Test Updates 1.4 MB/s | 328 kB 00:00
          Fedora 23 – x86_64 – Updates 4.6 MB/s | 20 MB 00:04
          Adobe Systems Incorporated 8.3 kB/s | 1.8 kB 00:00
          RPM Fusion for Fedora 23 – Free 2.5 MB/s | 738 kB 00:00
          Last metadata expiration check: 0:00:00 ago on Tue Mar 15 01:33:44 2016.
          repo id repo name status
          adobe-linux-x86_64 Adobe Systems Incorporated 2
          *fedora Fedora 23 – x86_64 46,074
          rpmfusion-free RPM Fusion for Fedora 23 – Free 692
          rpmfusion-free-updates-testing RPM Fusion for Fedora 23 – Free – Test Upd 261
          *updates Fedora 23 – x86_64 – Updates 17,125
          virtualbox Fedora 23 – x86_64 – VirtualBox 14
          [RBN@new-host-4 log]$ virtualbox
          WARNING: The vboxdrv kernel module is not loaded. Either there is no module
          available for the current kernel (4.4.4-301.fc23.x86_64) or it failed to
          load. Please recompile the kernel module and install it by

          sudo /sbin/rcvboxdrv setup

          You will not be able to start VMs until this problem is fixed.
          Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
          ^C
          [RBN@new-host-4 log]$ uname -r
          4.4.4-301.fc23.x86_64
          [RBN@new-host-4 log]$ rpm -qa VirtualBox\*
          VirtualBox-5.0.14-1.fc23.x86_64
          [RBN@new-host-4 log]$ ls /usr/lib/virtualbox/vboxdrv.sh -la
          ls: cannot access /usr/lib/virtualbox/vboxdrv.sh: No such file or directory
          [RBN@new-host-4 log]$ dnf list installed |grep VirtualBox
          VirtualBox.x86_64 5.0.14-1.fc23 @rpmfusion-free-updates-testing
          kmod-VirtualBox-4.2.3-300.fc23.x86_64.x86_64
          [RBN@new-host-4 log]$ ls -la /usr/src/kernels
          total 12
          drwxr-xr-x. 3 root root 4096 Mar 15 00:06 .
          drwxr-xr-x. 5 root root 4096 Mar 15 00:43 ..
          drwxr-xr-x. 23 root root 4096 Mar 15 00:06 4.4.4-301.fc23.x86_64
          [RBN@new-host-4 log]$ ls -la /usr/src
          total 20
          drwxr-xr-x. 5 root root 4096 Mar 15 00:43 .
          drwxr-xr-x. 12 root root 4096 Oct 29 17:21 ..
          drwxr-xr-x. 2 root root 4096 Jan 3 12:25 akmods
          drwxr-xr-x. 2 root root 4096 Sep 10 2015 debug
          drwxr-xr-x. 3 root root 4096 Mar 15 00:06 kernels
          [RBN@new-host-4 log]$ uname -a
          Linux new-host-4.home 4.4.4-301.fc23.x86_64 #1 SMP Fri Mar 4 17:42:42 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          [RBN@new-host-4 log]$ ls -la /etc/yum.repos.d/virtualbox.repo
          -rw-r–r–. 1 root root 241 Sep 30 10:43 /etc/yum.repos.d/virtualbox.repo
          [RBN@new-host-4 log]$ cat /etc/yum.repos.d/virtualbox.repo
          [virtualbox]
          name=Fedora $releasever – $basearch – VirtualBox
          baseurl=http://download.virtualbox.org/virtualbox/rpm/fedora/$releasever/$basearch
          enabled=1
          gpgcheck=1
          repo_gpgcheck=1
          gpgkey=https://www.virtualbox.org/download/oracle_vbox.asc

          Reply
          • Hi nik,

            Looks like that you have some other version of VirtualBox installed, could you post output of following command:

            
            dnf list installed |grep -i VirtualBox
            
            Reply
            • hey JR its working all the sudden i guess after trying every suggestting you posted for others it worked

              ….. But i think the problem is if you update fedora u get 4.4.4 kernel? while virtual box is up to 4.2.what ever

              after i switched kernels in boot it worked but i tried that before i dunno..

              thanks alot… not that i need virtual box i just couldnt move on in learning linux untill i got this right…. took a month untill someone gave me this site…

              anyway thanks for the help jr

              Reply
              • Hi nik,

                Kernel version is not problem. I run VirtualBox normally with 4.4.4 kernel. Problem is that you have wrong version of VirtualBox installed.

                Check difference, your output:

                
                rpm -qa VirtualBox\*
                VirtualBox-5.0.14-1.fc23.x86_64
                

                Same output when you use right package:

                
                rpm -qa VirtualBox\*
                VirtualBox-5.0-5.0.16_105871_fedora22-1.x86_64
                

                And problem is not between 5.0.14 and 5.0.16 versions, both works with kernel 4.4.4. Problem is that you have VirtualBox package installed and this guide uses VirtualBox-5.0 package.

                Again if you check output of following command:

                
                dnf list installed |grep -i VirtualBox
                

                It should be:

                
                VirtualBox-5.0.x86_64                    5.0.16_105871_fedora22-1  @virtualbox
                

                Most important part is last (repo) @virtualbox, if you have here something else than @virtualbox, then you have installed it using some other repo than virtualbox own repo.

                If you run following command:

                
                dnf install VirtualBox-5.0
                
                ## NOT ##
                # dnf install VirtualBox
                

                You get right package.

                Reply
                • well it started working so i think everything is fine it doesnt lunch from root tho dunno if thats by default but here is the terminal info does it look correct

                  [root@new-host-4 Downloads]# rpm-qaVirtualBox\*
                  VirtualBox-5.0.14-1.fc23.x86_64
                  [root@new-host-4 Downloads]# dnf list installed |grep -i VirtualBox
                  VirtualBox.x86_64 5.0.14-1.fc23 @rpmfusion-free-updates-testing
                  kmod-VirtualBox-4.2.3-300.fc23.x86_64.x86_64
                  [root@new-host-4 Downloads]# dnf repolist
                  Last metadata expiration check: 1:30:57 ago on Thu Mar 17 02:41:59 2016.
                  repo id repo name status
                  adobe-linux-x86_64 Adobe Systems Incorporated 2
                  *fedora Fedora 23 – x86_64 46,074
                  rpmfusion-free RPM Fusion for Fedora 23 – Free 692
                  rpmfusion-free-updates-testing RPM Fusion for Fedora 23 – Free – Test Updates 261
                  *updates Fedora 23 – x86_64 – Updates 17,205
                  virtualbox

                  Reply
                • hey jr still have the same problem everythng works fine when i load kernel 4.2.4.300 but then i load from oot 4.4.4.300 i get the rc=1900c..i live but i love solving these problems u said it should work on both

                  Reply
                  • Hi nik,

                    Yes, it will work when you remove RPMFusion VirtualBox package(s) and install Oracle’s own VirtualBox-5.0 package.

                    Reply
1 16 17 18 19 20 27

Leave a Reply to Consuelo Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Exit mobile version
Close