Zend Framework on Fedora 18/17, CentOS/Red Hat (RHEL) 6.4/5.9 - Comment Page: 2

This is quick guide, howto install Zend Framework (ZF) 1.12.3 on Fedora 18/17/16/15, CentOS 6.4/6.3/6.2/6.1/6/5.9 and Red Hat (RHEL) 6.4/6.3/6.2/6.1/6/5.9. This guide also works with older Fedora releases, like Fedora 13/12/11 and also with older CentOS/Red Hat RHEL 5 releases. I use Remi repository here because it's updated more frequently than example Fedora's own repositories. What is Zend Framework? Zend Framework is a simple, straightforward, open-source software framework for PHP 5 designed to eliminate the tedious details of coding and let you focus on the big picture. Its strength is in its highly-modular MVC design, making your code more reusable and easier to...

51 comments on “Zend Framework on Fedora 18/17, CentOS/Red Hat (RHEL) 6.4/5.9 - Comment Page: 2

1 2
    1. At step 2.3, I had dependencies problems. To fix them you need to run the command with the remi-test repo activated :

      yum --enablerepo=remi,remi-test install php-ZendFramework* --exclude php-ZendFramework-Db-Adapter-Oracle

      Reply
      • Hi Pierre-Luc,

        Thanks! What distro you are using?

        Reply
        • We’re using CentOS 6.2.

          Reply
          • Okay, I just tested this with CentOS 6.2 and 6.3. Zend Framework works normally with PHP 5.3 and remi-test is not needed on clean installed system. Do you had PHP 5.4 already installed?

            Reply
    2. Greate, how about ZF2 RC? is it the same way?

      Reply
      • Hi Brendan,

        This method works currently only with ZF 1. You can check this page to get ZF 2.

        Reply
    3. I get error when I try to install Zend.
      When running this: yum –enablerepo=remi install php-ZendFramework* –exclude php-ZendFramework-Db-Adapter-Oracle


      Transaction Check Error:
      file /etc/my.cnf from install of mysql-libs-5.5.28-1.el5.remi.i386 conflicts w ith file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.5.28-1.e l5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/czech/errmsg.sys from install of mysql-libs-5.5.28-1.el5 .remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/danish/errmsg.sys from install of mysql-libs-5.5.28-1.el 5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/dutch/errmsg.sys from install of mysql-libs-5.5.28-1.el5 .remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/english/errmsg.sys from install of mysql-libs-5.5.28-1.e l5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/estonian/errmsg.sys from install of mysql-libs-5.5.28-1. el5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/french/errmsg.sys from install of mysql-libs-5.5.28-1.el 5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/german/errmsg.sys from install of mysql-libs-5.5.28-1.el 5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/greek/errmsg.sys from install of mysql-libs-5.5.28-1.el5 .remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-libs-5.5.28-1 .el5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/italian/errmsg.sys from install of mysql-libs-5.5.28-1.e l5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/japanese/errmsg.sys from install of mysql-libs-5.5.28-1. el5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/korean/errmsg.sys from install of mysql-libs-5.5.28-1.el 5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-libs-5.5.2 8-1.el5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i 386
      file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-libs-5.5.28-1 .el5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/polish/errmsg.sys from install of mysql-libs-5.5.28-1.el 5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-libs-5.5.28- 1.el5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i38 6
      file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.5.28-1. el5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.5.28-1.e l5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.5.28-1.e l5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.5.28-1.el 5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.5.28-1.e l5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.5.28-1.e l5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386
      file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.5.28-1 .el5.remi.i386 conflicts with file from package MySQL-server-5.5.16-1.rhel5.i386

      Error Summary

      What do I need to do?

      Reply
      • Hi,

        Could you post output of following commands:

        
        yum repolist
        
        yum info mysql-server mysql-libs mysql
        
        uname -a
        
        lsb_release -a
        
        Reply
    4. Ok here is the result for each of them:


      yum repolist

      Loaded plugins: fastestmirror
      Loading mirror speeds from cached hostfile
      * epel: nl.mirror.eurid.eu
      addons | 1.9 kB 00:00
      base | 1.1 kB 00:00
      epel | 3.7 kB 00:00
      extras | 2.1 kB 00:00
      update | 1.9 kB 00:00
      utterramblings | 951 B 00:00
      repo id repo name status
      addons CentOS-5 - Addons enabled: 0
      base CentOS-5 - Base enabled: 2725
      epel Extra Packages for Enterprise Linux 5 - i386 enabled: 5827
      extras CentOS-5 - Extras enabled: 276
      update CentOS-5 - Updates enabled: 75
      utterramblings Jason's Utter Ramblings Repo enabled: 201
      repolist: 9104

      yum info mysql-server mysql-libs mysql
      Loaded plugins: fastestmirror
      Loading mirror speeds from cached hostfile
      * epel: nl.mirror.eurid.eu
      addons | 1.9 kB 00:00
      base | 1.1 kB 00:00
      epel | 3.7 kB 00:00
      extras | 2.1 kB 00:00
      update | 1.9 kB 00:00
      utterramblings | 951 B 00:00
      Installed Packages
      Name : MySQL-server
      Arch : i386
      Version : 5.5.16
      Release : 1.rhel5
      Size : 139 M
      Repo : installed
      Summary : MySQL: a very fast and reliable SQL database server
      URL : http://www.mysql.com/
      License : Copyright (c) 2000, 2011, Oracle and/or its affiliates. All rights reserved. Under GPL license as shown in the Description field.
      Description: The MySQL(TM) software delivers a very fast, multi-threaded,
      : multi-user, and robust SQL (Structured Query Language) database
      : server. MySQL Server is intended for mission-critical, heavy-load
      : production systems as well as for embedding into mass-deployed
      : software. MySQL is a trademark of Oracle and/or its affiliates
      :
      : The MySQL software has Dual Licensing, which means you can use the
      : MySQL software free of charge under the GNU General Public License
      : (http://www.gnu.org/licenses/). You can also purchase commercial
      : MySQL licenses from Oracle and/or its affiliates if you do not wish
      : to be bound by the terms of the GPL. See the chapter "Licensing and
      : Support" in the manual for further info.
      :
      : The MySQL web site (http://www.mysql.com/) provides the latest news
      : and information about the MySQL software. Also please see the
      : documentation and the manual for more information.
      :
      : This package includes the MySQL server binary as well as related
      : utilities to run and administer a MySQL server.
      :
      : If you want to access and work with the database, you have to
      : install package "MySQL-client" as well!

      Available Packages
      Name : mysql
      Arch : i386
      Version : 5.1.58
      Release : jason.1
      Size : 3.5 M
      Repo : utterramblings
      Summary : MySQL client programs and shared libraries
      URL : http://www.mysql.com
      License : GPLv2 with exceptions
      Description: MySQL is a multi-user, multi-threaded SQL database server. MySQL is
      : a client/server implementation consisting of a server daemon
      : (mysqld) and many different client programs and libraries. The base
      : package contains the standard MySQL client programs and generic
      : MySQL files.

      Name : mysql-server
      Arch : i386
      Version : 5.1.58
      Release : jason.1
      Size : 13 M
      Repo : utterramblings
      Summary : The MySQL server and related files
      URL : http://www.mysql.com
      License : GPLv2 with exceptions
      Description: MySQL is a multi-user, multi-threaded SQL database server. MySQL is
      : a client/server implementation consisting of a server daemon
      : (mysqld) and many different client programs and libraries. This
      : package contains the MySQL server and some accompanying files and
      : directories.

      uname -a
      ip.secureserver.net 2.6.18-028stab099.3 #1 SMP Wed Mar 7 15:20:22 MSK 2012 i686 i686 i386 GNU/Linux

      lsb_release -a = command not found

      Reply
      • Hi Zend Help,

        Could you also post output of following command:

        
        yum list all mysql-server
        
        Reply
    5. yum list all mysql-server
      Loaded plugins: fastestmirror
      Loading mirror speeds from cached hostfile
      * epel: nl.mirror.eurid.eu
      addons | 1.9 kB 00:00
      base | 1.1 kB 00:00
      epel | 3.7 kB 00:00
      epel/primary_db | 3.1 MB 00:00
      extras | 2.1 kB 00:00
      update | 1.9 kB 00:00
      utterramblings | 951 B 00:00
      Installed Packages
      MySQL-server.i386 5.5.16-1.rhel5 installed
      Available Packages
      mysql-server.i386 5.1.58-jason.1 utterramblings

      Here you go.

      Reply
      • Thanks, it looks like your current installation MySQL-server.i386 5.5.16-1.rhel5 conflict with remi repository mysql-server 5.5.28. So if you could upgrade your mysql-server to latest 5.5.28, then it should work. Please remeber backup (dump) your databases before upgrade.

        Reply
    6. hi, do you know how to make zend framework work on nginx?

      Reply
    7. [[email protected] ~]$ zf show version
      PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/oci8.so’ – libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
      PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/pdo_oci.so’ – libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
      Zend Framework Version: 1.12.1

      [[email protected] ~]$

      please help me

      Reply
      • Hi rais,

        Do you need Oracle database adapter?

        Reply
        • Hai JR, i have same a problem with rais..
          can you help me???

          Reply
          • Hi dibyo,

            Same question to you. Do you need/use Oracle database adabter?

            Reply
            • no, i was following step by step from you sir..

              Reply
              • Hi Dibyo,

                Could you post output of following command:

                
                rpm -qa php-ZendFramework\*
                
                Reply
                • this output :
                  php-ZendFramework-Cache-Backend-Memcached-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-extras-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Db-Adapter-Firebird-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Cache-Backend-Sqlite-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Soap-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Db-Adapter-Mysqli-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Db-Adapter-Pdo-Mysql-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Cache-Backend-Apc-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Captcha-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Feed-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-demos-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Db-Adapter-Pdo-Mssql-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Pdf-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Auth-Adapter-Ldap-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Db-Adapter-Pdo-Pgsql-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Dojo-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Services-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Db-Adapter-Pdo-Oci-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Cache-Backend-Libmemcached-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Ldap-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Db-Adapter-Pdo-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Serializer-Adapter-Igbinary-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-full-1.12.3-1.fc17.remi.noarch
                  php-ZendFramework-Search-Lucene-1.12.3-1.fc17.remi.noarch

                  but if i write this code :
                  zf show version
                  output :
                  PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/oci8.so’ – libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
                  PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/pdo_oci.so’ – libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
                  Zend Framework Version: 1.12.3

                  :)

                  Reply
                  • Try simply remove php-ZendFramework-Db-Adapter-Pdo-Oci package:

                    
                    yum remove php-ZendFramework-Db-Adapter-Pdo-Oci
                    

                    Then try again:

                    
                    zf show version
                    
                    Reply
                    • same result bro…
                      PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/oci8.so’ – libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
                      PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/modules/pdo_oci.so’ – libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0

                      do i must reinstall fedora???

                      Reply
                      • Hi dibyo,

                        No you don’t have to reinstall Fedora.

                        Remove also following and it’s dependencies:

                        
                        yum remove php-oci8
                        

                        Then try once again.

    8. thanks JR for your help..
      now i can use zend, with step by step from your tutorial..

      Reply
      • Hi Dibyo,

        Excellent, you are welcome! I updated this guide too.

        Reply
        • hi JR, can you help me about instalation cakephp in fedora??? :)

          regard.
          dibyo

          Reply
          • Hi dibyo,

            First I thought that I write totally separated guide, but actually you can install it very simply, when you have LAMP installed, just install git:

            
            yum install git
            

            And then follow CakePHP install guide.

            Reply
    9. Really a good tutorial..thanks a lot.

      Reply
    10. I am looking for the same.

      Reply
    11. I had install zendframework 2.2.5 by using below command

      yum –enablerepo=remi install php-ZendFramework2* –exclude php-ZendFramework-Db-Adapter-Oracle –exclude php-ZendFramework-Db-Adapter-Pdo-Oci

      but unable to run version 2
      after removing version 2.2.5 and reinstall Zend Framework Version: 1.12.3 its running but I have to install and run version 2 please help

      Reply
1 2

Leave a Reply to Pierre-Luc Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close