If Not True Then False

Fedora 16 nVidia Drivers Install Guide (disable nouveau driver) - Comment Page: 10

Looking Fedora 22/21 nVidia Drivers Install Guide? This is guide, howto install nVidia proprietary drivers on Fedora 16 and disable Nouveau driver. This guide works with GeForce 6/7/8/9/200/300 series cards. Fedora 16 nVidia driver installation is not much different from previous Fedora versions. I have tested this guide with a couple computers, so let me know, if you have some...
Categories:

494 Comments

Leave a Comment

Your email address will not be published. Required fields are marked *

Input your comment.
help

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Input your name.

torsten

This is my

lsmod |grep -e nvidia -e nouveau

nvidia 10987898 0
i2c_core 28151 2 nvidia,i2c_viapro

If you need anymore info let me know.

Thanks in advance.

reply Reply
JR

Hi torsten,

First try to boot runlevel 3 and then login as root and try run following command:


systemctl start akmods.service

If it works without errors then reboot your system. Is nVidia drivers working then?

reply Reply
torsten

No luck.

systemctl start akmods.service

fails with

akmods.service - LSB: Builds and install new kmods from akmod packages
Loaded: loaded (/etc/rc.d/init.d/akmods)
Active: failed since Thu, 06 Sep 2012 18:46:54 +0200; 4min 5s ago
Process: 1318 ExecStart=/etc/rc.d/init.d/akmods start (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/akmods.service


uname -a


Linux phoebe 3.4.9-2.fc16.i686 #1 SMP Thu Aug 23 19:15:34 UTC 2012 i686 i686 i386 GNU/Linux


grep EE for Xorg.0.log


(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 23.182] (II) Loading extension MIT-SCREEN-SAVER

reply Reply
JR

What if you try to boot again runlevel 3 and start akmods directly:


/etc/rc.d/init.d/akmods start

And if it runs ok, then reboot and test is your nVidia drivers working then?

reply Reply
torsten

Still not working.

/etc/rc.d/init.d/akmods start worked ok, but rebooting still gives the old errors.

systemctl status akmods.service still fails with the same error.

reply Reply
JR

Hi torsten,

It’s strange, if akmods runs ok, but rebooting still give same errors. Next thing to try is pre-built kmod.

You can remove akmod and install kmod with following commands:


yum remove akmod-nvidia

yum install kmod-nvidia

Then check that just installed kmod-version match your kernel version and reboot. Is it still failing?

reply Reply
JR

Excellent! You are welcome!

Some reason akmod building will fail on some systems and then it’s better use pre-built kmod drivers. :)

reply Reply
Trent

The -> Add RPMFusion Repositories (Free and Non-Free) links are now broken for F16..Only supports F17 and above

reply Reply
Caolan

I am getting a failure on this.

[root@khazad-dum Downloads]# lspci | grep -i VGA
03:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8700M GT] (rev a1)

[root@khazad-dum Downloads]# yum update kernel* selinux-policy*
Loaded plugins: langpacks, presto, refresh-packagekit
No Packages marked for Update
[root@khazad-dum Downloads]# rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
Retrieving http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
warning: /var/tmp/rpm-tmp.zhZPHW: Header V3 RSA/SHA256 Signature, key ID 8296fa0f: NOKEY
error: Failed dependencies:
system-release >= 17 is needed by rpmfusion-free-release-17.0.5-1.noarch
[root@khazad-dum Downloads]# yum install akmod-nvidia xorg-x11-drv-nvidia-libs
Loaded plugins: langpacks, presto, refresh-packagekit
No package akmod-nvidia available.
No package xorg-x11-drv-nvidia-libs available.
Error: Nothing to do
[root@khazad-dum Downloads]# yum install kmod-nvidia xorg-x11-drv-nvidia-libs
Loaded plugins: langpacks, presto, refresh-packagekit
No package kmod-nvidia available.
No package xorg-x11-drv-nvidia-libs available.
Error: Nothing to do

reply Reply
JR

Hi Caolan,

I have normally just linked to new guides (but I update this guide with extra information). Yes you are right, no more RPM Fusion repos, they don’t maintain any repos when Fedora version reached End of Life (EOL).

reply Reply