Install Skype 8.61 on Fedora 32/31, CentOS/RHEL/SL 8.0/7.7 - Comment Page: 20

This is guide, howto install Skype 8.61 on Fedora 32/31/30/29/28 on CentOS/Red Hat (RHEL)/Scientific Linux (SL) 8.0/7.7. This is actually easy process, I updated this guide and use Skype own RPM package, because it's currently only way the install Skype. Skype 4.3 and older versions are outdated after July 1. 2017. Notice From Skype download page: Important notice: All Skype for Linux clients version 4.3 and older will be retired on July 1, 2017. To keep chatting, please install the latest version of Skype for Linux. 1. Install Skype 8.61 on Fedora 32/31/30/29/28 and CentOS/Red Hat (RHEL) 8.0/7.7 [inttf_post_ad1] 1.1 Change root user su - ## OR ## sudo -i 1.2...

707 comments on “Install Skype 8.61 on Fedora 32/31, CentOS/RHEL/SL 8.0/7.7 - Comment Page: 20

1 18 19 20 21 22 25
    1. Hello, worked flawlessly with Fedora 22,
      Thank you very much !

      Reply
    2. hi
      my error when type “skype” on terminal :

      /usr/bin/skype: line 5: 3804 Segmentation fault (core dumped) $SKYPE_HOME/skype –resources=$SKYPE_HOME $*

      Centos 6
      #!/bin/sh
      export SKYPE_HOME=”/usr/src/skype”
      export GTK2_RC_FILES=”/etc/gtk-2.0/gtkrc”

      $SKYPE_HOME/skype –resources=$SKYPE_HOME $*

      Reply
    3. Excellent! Thank you very much

      Reply
    4. Error installing dependencies:

      Running transaction check
      Transaction check succeeded.
      Running transaction test
      The downloaded packages were saved in cache till the next successful transaction.
      You can remove cached packages by executing ‘dnf clean packages’.
      Error: Transaction check error:
      file /usr/share/doc/freetype/CHANGES from install of freetype-2.5.5-2.fc22.i686 conflicts with file from package freetype-2.5.5-1.fc22.x86_64

      Error when starting Skype from command line:

      [[email protected] ~]$ skype
      /usr/bin/skype: /opt/skype/skype: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

      Reply
      • Hi GAM,

        Run dnf update first:

        
        dnf update
        

        And then try again install dependencies.

        Reply
        • Hi JR,

          Thanks I did that and got no errors when dependencies installed. However, when I try to launch skype, I now get this:

          [[email protected] ~]$ skype
          /usr/bin/skype: line 4: 2491 Segmentation fault (core dumped) $SKYPE_HOME/skype –resources=$SKYPE_HOME $*

          Reply
          • Hi GAM,

            Do you have nVidia drivers installed?

            Could you post output of following command (example to http://pastebin.com):

            
            strace /usr/bin/skype
            
            Reply
            • Hi JR,

              Yes, I do have nVidia drivers installed. Does that foil things?

              Output of this wasn’t very exciting:

              [[email protected] Desktop]# strace /usr/bin/skype
              bash: strace: command not found

              Reply
              • Yes, sometimes nVidia drivers cause problems with Skype.

                What version of nVidia drivers you have installed?
                And do you have 32-bit compatibility libraries installed?

                Could you also post output of following commands:

                
                updatedb;locate libGL |xargs ls -la
                
                grep -v "#" /etc/sysconfig/selinux |grep -v -e '^$'
                

                You can install strace using command:

                
                dnf install strace
                
                Reply
                • Hi JR,

                  I tried to post that output, but was blocked by the site. Please advise.

                  Reply
                      • Hi Louis,

                        What OS you are running? Did you installed 32-bit support on your nVidia drivers?

                        I have to test this again with nVidia drivers.

                      • I’m running Fedora 23 64bit – fresh install and updated.
                        Linux 4.2.5-300.fc23.x86_64 #1 SMP Tue Oct 27 04:29:56 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux.

                        And yes i did install the 32 bit compatibility libraries.

                      • Have the same problem too. Fedora 23, nvidia+32bit libraries.

                      • Hi GAM, Louis and Ivan

                        Add following row to your /usr/bin/skype file:

                        
                        #!/bin/sh
                        export LD_PRELOAD="/usr/lib/libGL.so.1.2.0"
                        export SKYPE_HOME="/opt/skype"
                         
                        $SKYPE_HOME/skype --resources=$SKYPE_HOME $*
                        

                        I tested this quickly on Fedora 23 and Skype starts.

                      • That’s it. It works.

                        Thanks

                      • I had the same problem and it solved them!
                        Thanks!

        • This is just to report that I updated from Fed 21 to Fed23 recently. The Skype that I had installed for Fed21 using your instructions works fine. No rebuild required.

          dnf (successor to yum) doesn’t seem to know about it
          however:
          dnf list skype
          Last metadata expiration check performed 0:10:55 ago on Mon Nov 30 10:11:49 2015.
          Error: No matching Packages to list
          [[email protected] ~]$ dnf info skype
          Last metadata expiration check performed 0:11:10 ago on Mon Nov 30 10:11:49 2015.
          Error: No matching Packages to list

          Reply
          • Hi Art Olin,

            Yes, dnf (or yum) doesn’t find/see skype, because it’s installed from tar package directly to filesystem.

            Reply
    5. Hi JR,

      I am sysadmin and facing skype fonts fuzziness issue on many centos 7 systems. On centos 7 skype sometime work but sometime chat windows fonts overlap.
      file:///home/anuj/Desktop/skype_fuzziness.png

      Reply
    6. Hello,

      I have a problem installing qtwebkit.i686 in a CentOS 6.7. If I search for the package I receive the error “No package qtwebkit.i686 available” but if I try to install “yum install qtwebkit” it fails because the package needs other dependencies. Please your help!

      Reply
      • Hi rioujin,

        Could you post output of following command:

        
        yum repolist
        
        Reply
        • Hello, thank you for your reply. Following the output of the command:

          epel/metalink | 2.6 kB 00:00
          * base: centos.zeotec.cl
          * epel: epel.gtdinternet.com
          * extras: centos.zeotec.cl
          * updates: centos.zeotec.cl
          base | 3.7 kB 00:00
          extras | 3.4 kB 00:00
          updates | 3.4 kB 00:00
          updates/primary_db | 1.9 MB 00:00
          repo id repo name status
          base CentOS-6 – Base 6,575
          epel Extra Packages for Enterprise Linux 6 – x86_64 8,653
          extras CentOS-6 – Extras 44
          updates CentOS-6 – Updates 466

          Reply
          • Hello rioujin,

            Could you first run:

            
            yum update
            

            Then:

            
            yum install qtwebkit.i686
            

            If it still fails, could you post your install command output here?

            Reply
            • Hello,

              Thank you for your help. The first time when I tried to run “yum update” the command failed with due to dependencies so I had to remove the EPEL repository, restart the system and reinstall the EPEL repository and now everything is ok, skype is working on CentOS 6,7!

              Reply
    7. tHANKS BUDS!!! IT REALLY WORKED OUT!!

      BEST REGARDS

      EA

      Reply
    8. On Fedora 22 with KDE (Plasma 5), skype is not shown in tray.
      In order to fix it I’ve installed:
      dnf install sni-qt.i686

      After that:
      1) Alt+F2 -> Skype -> Enter
      2) In main meny -> Exit
      3) Alt+F2 -> Skype -> Enter

      Bingo :)

      Reply
    9. I have problem
      /opt/skype/skype: error while loading shared libraries: libXv.so.1: cannot open shared object file: No such file or directory

      Reply
      • Hi Maxim,

        Did you installed all dependencies successfully on step 1.3?

        You need libXv.i686

        Reply
      • Is this library installed?
        libXv.i686 : X.Org X11 libXv runtime library

        Reply
    10. Hi JR,
      On F23 GNOME RC3 x64 I think this library is also needed: libxcb.i686
      Still there is a dependency problem, see below:
      Error: package qt-1:4.8.7-3.fc23.i686 requires libsqlite3.so.0, but none of the providers can be installed.
      package pulseaudio-libs-7.0-1.fc23.i686 requires libsystemd.so.0, but none of the providers can be installed.
      package glib2-2.46.1-1.fc23.i686 requires libselinux.so.1, but none of the providers can be installed.
      package qtwebkit-2.3.4-8.fc23.i686 requires libgstpbutils-1.0.so.0, but none of the providers can be installed
      (try to add ‘–allowerasing’ to command line to replace conflicting packages)

      Have to give it a closer look later.

      Reply
    11. thank you so much guys its working fine really really helpful & a cake walk by above steps.

      Reply
    12. Thanks! It works like charm on my fedora 22 , 64 bit

      Reply
    13. Hi JR,

      i have encountered skype crash when running on fedora 23, probably similar/same to GAM has.
      I’m running on Fedora with downgraded x11 as per your nvidia drivers instruction. As i have NVS 3100, i’m running nvidia 340.xx with 32 libraries installed.

      strace output (from command “strace -v -o skype.txt skype”) is on http://pastebin.com/djpsYqf8

      At first it wrote about not able to find libc.mo in /usr/share/locale/en_US/LC_MESSAGES (and similar directories). After switching to Czech locale it can find libc.mo but still crashes. No idea why now.

      Reply
      • Hi JR – the solution you have posted for GAM (export LD_PRELOAD) is working for me as well. Thank you.

        Reply
        • Hi Martin,

          In fact, this was meant for you, too of course. Skype won’t start with nVidia version of libGL.

          Reply
    14. I have Fedora 23, aftter download Skype i have run comand as 1.5.
      #tar xvf skype-4.3* -C /opt/skype –strip-components=1
      tar: /opt/skype: funzione “open” non riuscita: File o directory non esistente
      tar: Error is not recoverable: exiting now

      Resolved with “mkdir /opt/skype” before run tar command

      Reply
      • Sorry!
        It’s all ok

        Reply
    15. Hi,

      thank you for your help.
      When I try to start skype :

      /bin/skype: /opt/skype/skype: /lib/ld-linux.so.2: bad ELF interpreter

      Reply
      • Hi Olivier,

        Did you installed needed dependencies on step 1.3?

        Reply
        • Hi JR,
          Sorry I didn’t notied that I received errors at this step… I did a dnf updates and now it’s works !

          Thank you.

          Reply
1 18 19 20 21 22 25

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close