Install Skype 8.18 on Fedora 28/27, CentOS/RHEL/SL 7.4 - Comment Page: 23

This is guide, howto install Skype 8.18 on Fedora 28/27/26/25 on CentOS/Red Hat (RHEL)/Scientific Linux (SL) 7.4. This is actually easy process, I updated this guide and use Skype own RPM package, because it's currently only way the install Skype. Skype 4.3 and older versions are outdated after July 1. 2017. Notice From Skype download page: Important notice: All Skype for Linux clients version 4.3 and older will be retired on July 1, 2017. To keep chatting, please install the latest version of Skype for Linux. 1. Install Skype 8.18 on Fedora 28/27/26/25 and CentOS/Red Hat (RHEL) 7.4 [inttf_post_ad1] 1.1 Change root user su - ## OR ## sudo -i 1.2 Download Skype...

690 comments on “Install Skype 8.18 on Fedora 28/27, CentOS/RHEL/SL 7.4 - Comment Page: 23

1 21 22 23 24
    1. This tutorial was MAGICAL except that I seem to have created my icon so that it opens Skype 4.0.0.8, which doesn’t sign in. If I manually go by the command line to the 4.3.0.37 directory and type ./skype, it works fine. Can you tell me how to change the icon to point to the right version of Skype…and/or tell me how to remove the other non-working ones?

      I’m on Fedora 23. Thank you!!

      Reply
      • Hi Ray,

        Do you have older Skype 4.0.0.8 installed on your system?

        Could you also post output of following commands:

        
        ls -la /usr/share/applications/skype.desktop
        
        cat /usr/share/applications/skype.desktop
        
        Reply
        • Yes, I _do_ have 4.0.0.8 installed since it opens up (but won’t let me log in). It might have installed with easyLife? Or perhaps I tried a different method to install and it didn’t work. As long as I go to the 4.0.0.37 directory and launch Skype from that directory it works great. But not via the icon. Here’s the output:

          lrwxrwxrwx. 1 root root 24 May 22 13:29 /usr/share/applications/skype.desktop -> /opt/skype/skype.desktop

          cat /usr/share/applications/skype.desktop
          [Desktop Entry]
          Name=Skype
          Comment=Skype Internet Telephony
          Exec=skype %U
          Icon=skype.png
          Terminal=false
          Type=Application
          Encoding=UTF-8
          Categories=Network;Application;
          MimeType=x-scheme-handler/skype;
          X-KDE-Protocols=skype

          Will it help if I edit the desktop file to say Exec=/correct/dir/to/skype U% ??

          Reply
          • Okay, It’s maybe better remove 4.0.0.8 installation first.

            Could you post output of following command:

            
            rpm -qa |grep -i skype
            
            Reply
            • That query returned no results.

              Reply
              • Could then post output of following commands:

                
                ls -la /usr/bin/skype
                
                cat /usr/bin/skype
                
                Reply
                • Here you go (sorry this took so long, I was traveling…)

                  ls -la /usr/bin/skype:
                  -rwxr-xr-x. 1 root root 87 May 22 22:47 /usr/bin/skype

                  cat /usr/bin/skype:
                  #!/bin/sh
                  export SKYPE_HOME=”/opt/skype”

                  $SKYPE_HOME/skype –resources=$SKYPE_HOME $*

                  Reply
    2. I have an error

      /usr/bin/skype: line 4: 12465 Segmentation fault (core dumped) $SKYPE_HOME/skype –resources=$SKYPE_HOME $*

      Can you help me?

      Reply
      • Hi Jean,

        What OS you are running and do you have nVidia drivers installed?

        Reply
        • I’ve installed the Fedora 24, and yes i have Nvidia drivers. But i already fix the problem, i changed the driver from 340 to 367.27.

          Reply
        • Hi, I have the same problem with Fedora 24. I also have Nvidia drivers 340.96 installed following your instruction. What can you advice?

          Reply
          • Update the version of driver Nvidia to 367.

            Reply
          • Update the driver of Nvidia to 367.

            Reply
      • I discovered that reinstalling the nvidia driver (352.63) was enough to solve the problem. So apparently is better to install skype before the nvidia driver to avoid the issue…

        Reply
    3. Same stuff for me with segmentation fault in Oracle Linux 6.8

      Reply
      • Hi Mike,

        I haven’t tested this on Oracle Linux 6.8, but when I last time checked this worked on CentOS/RHEL 6.8. I can recheck at least on CentOS 6.8.

        Reply
    4. Thanks a lot! This tutoriel is awesome and works like a charm!

      Reply
    5. Good afternoon!

      Could you, please, also describe an algorithm on skype uninstallation?

      Kind regards.

      Reply
      • The problem with that is that it is alpha.
        Missing features include adding contacts and calling mobiles and landlines (ie its just like a buggy im app)

        Reply
    6. Hello JR,

      I am on Fedora 24 and I have the same problem and same output than Ray. I don’t see answer after 5th june. Thank you.

      Reply
      • Hello JH,

        Do you mean that you have older skype version installed too? And when you click Skype icon it opens 4.0.0.8 version?

        Reply
    7. Howdy: I am running Fedora 24 on a 64-bit Dell Optiplex 760. I’ll need to download and install some drivers for a video cam that I have not tried to use before on this computer. Please, could you advise me where to learn how to get the right driver(s) and install them so that when I install Skype, I’ll be able to run it? – Thanks & All th’ e-Best – Rusty

      Reply
    8. I tried with many installation instructions of Skype in Fedora-23. This is one of the easy and smooth sailing on installation of Skype in F-23. Thank you very much.

      Reply
    9. Thank you for the instructions! I got the following error after starting skype after installing it on Fedora 25:
      $ skype

      (skype:8811): Gtk-WARNING **: Unable to locate theme engine in module_path: “adwaita”,

      (skype:8811): Gtk-WARNING **: Unable to locate theme engine in module_path: “adwaita”,
      Gtk-Message: Failed to load module “pk-gtk-module”
      Gtk-Message: Failed to load module “canberra-gtk-module”

      Wondering if these are required for normal skype work.

      The reason I was looking into this installation was that my skype has lost sound and I was wondering if the previous F25 update removed/modified some skype related stuff. The skype was installed back at the Fedora 16 level and it could be some “inheritance” that caused its failure.

      # uname -a
      Linux 4.8.12-300.fc25.x86_64 #1 SMP Fri Dec 2 17:52:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

      Reply
    10. There’no sound without pulse and alsa libraries, if you install KDE spin. Don’t forget to install i686 versions, Qt and etc libraries.

      Reply
    11. Nice description … thanks!

      Reply
    12. Installation works like a breeze!

      Reply
1 21 22 23 24

Leave a Reply

Your email address will not be published. Required fields are marked *

Close