Install Skype 8.50 on Fedora 30/29, CentOS/RHEL/SL 7.6 - Comment Page: 3

This is guide, howto install Skype 8.50 on Fedora 30/29/28/27 on CentOS/Red Hat (RHEL)/Scientific Linux (SL) 7.6. This is actually easy process, I updated this guide and use Skype own RPM package, because it's currently only way the install Skype. Skype 4.3 and older versions are outdated after July 1. 2017. Notice From Skype download page: Important notice: All Skype for Linux clients version 4.3 and older will be retired on July 1, 2017. To keep chatting, please install the latest version of Skype for Linux. 1. Install Skype 8.50 on Fedora 30/29/28/27 and CentOS/Red Hat (RHEL) 7.6 [inttf_post_ad1] 1.1 Change root user su - ## OR ## sudo -i 1.2 Download Skype...

704 comments on “Install Skype 8.50 on Fedora 30/29, CentOS/RHEL/SL 7.6 - Comment Page: 3

1 2 3 4 5 25
    1. Hi JR,
      Could yoy help me, pls?
      I cannot run “tar xvf skype_static* -C /opt/skype –strip-components=1”
      I’m on fedora 17. As it’s a new installation I got as “tar” it’s not installed so after googling I run “# yum install per-Archive-Tar (source:http://pkgs.org/fedora-17/fedora-updates-i386/perl-Archive-Tar-1.76-212.fc17.noarch.rpm.html). Now I got tar.i686 2:1.26-7.fc17 (I dunno if it was correct(¿?)).
      As I still could not do it, I run “#yum install tar”. Now I got “tar.i686 2:1.26-7.fc17”, and what I got now is:
      “tar: skype_static*: Can’t open: file or dir doesn’t exist
      tar: Error is not recoverable: exiting now”
      I’d appreciate any clue on this issue.
      Thanks.

      Reply
      • Hi txe,

        Looks like you have tar installed now. One thing is changed on Skype download and I updated this guide too, so download Skype with following command to get right filename:

        
        wget --trust-server-names http://www.skype.com/go/getskype-linux-beta-static
        

        And then follow this guide. Please let me know if you have any problems?

        Reply
        • Hi, Thanks JR.
          This time I could install it but I got issues. When start skype from cli I got this report:
          “$ skype
          /opt/skype/skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory”
          any help?

          Reply
          • Good to hear that you got Skype installed, did you installed all dependencies on step 1.2?

            /opt/skype/skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory refers missing libXScrnSaver.i686 package.

            Reply
            • Hi JR,
              Yes I did as you guided above with not issues at sight.. Should I run that step enterely again?
              Thanks for your soon reply..
              Txe.

              Reply
              • Yes try to run it again and if you some problems then please post yum install command output here?

                Reply
    2. Hi JR,
      Still unsuccessful. I ran the step 1.2 again and this is what I got:

      “# yum install alsa-lib.i686 fontconfig.i686 freetype.i686 glib2.i686 libSM.i686 libXScrnSaver.i686 libXi.i686 libXrandr.i686 libXrender.i686 libXv.i686 libstdc++.i686 pulseaudio-libs.i686 qt.i686 qt-x11.i686 zlib.i686
      Loaded plugins: langpacks, presto, refresh-packagekit
      Package alsa-lib-1.0.25-3.fc17.i686 already installed and latest version
      Package freetype-2.4.8-3.fc17.i686 already installed and latest version
      Package libSM-1.2.1-1.fc17.i686 already installed and latest version
      Package libXi-1.6.1-1.fc17.i686 already installed and latest version
      Package libXrandr-1.3.1-3.fc17.i686 already installed and latest version
      Package libXrender-0.9.7-1.fc17.i686 already installed and latest version
      Package libXv-1.0.7-1.fc17.i686 already installed and latest version
      Package libstdc++-4.7.0-5.fc17.i686 already installed and latest version
      Package pulseaudio-libs-1.1-9.fc17.i686 already installed and latest version
      Package 1:qt-x11-4.8.2-4.fc17.i686 already installed and latest version
      Package zlib-1.2.5-7.fc17.i686 already installed and latest version
      Resolving Dependencies
      –> Running transaction check
      —> Package fontconfig.i686 0:2.8.0-6.fc17 will be updated
      —> Package fontconfig.i686 0:2.8.0-7.fc17 will be an update
      —> Package glib2.i686 0:2.32.1-1.fc17 will be updated
      —> Package glib2.i686 0:2.32.4-1.fc17 will be an update
      —> Package libXScrnSaver.i686 0:1.2.2-1.fc17 will be installed
      —> Package qt.i686 1:4.8.1-10.fc17 will be updated
      —> Package qt.i686 1:4.8.2-4.fc17 will be an update
      –> Finished Dependency Resolution

      Dependencies Resolved

      ================================================================================
      Package Arch Version Repository Size
      ================================================================================
      Installing:
      libXScrnSaver i686 1.2.2-1.fc17 fedora 22 k
      Updating:
      fontconfig i686 2.8.0-7.fc17 updates 186 k
      glib2 i686 2.32.4-1.fc17 updates 1.9 M
      qt i686 1:4.8.2-4.fc17 updates 4.4 M

      Transaction Summary
      ================================================================================
      Install 1 Package
      Upgrade 3 Packages

      Total size: 6.6 M
      Is this ok [y/N]: y
      Downloading Packages:
      Running Transaction Check
      Running Transaction Test

      Transaction Check Error:
      package glib2-2.32.4-1.fc17.i686 is already installed
      package qt-1:4.8.2-4.fc17.i686 is already installed
      package fontconfig-2.8.0-7.fc17.i686 is already installed

      Error Summary
      ————-

      [[email protected] tamara]# ”

      and the yum install command output is:
      “# yum install
      Loaded plugins: langpacks, presto, refresh-packagekit
      Error: Need to pass a list of pkgs to install
      Mini usage:

      install PACKAGE…

      Install a package or packages on your system

      aliases: install-n, install-na, install-nevra
      [[email protected] tamara]# ”

      Help, pls.
      Txe

      Reply
      • Try to run following commands:

        
        yum update
        
        yum install libXScrnSaver.i686
        

        Do you get libXScrnSaver installed then?

        Reply
        • Oh, yeah!!!.
          I got the output posted below but immediatelly all ran ferpect!!!
          The ouput for learning purposes was:
          [[email protected] tamara]# skype

          ” (process:1765): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
          Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

          (process:1765): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
          Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

          (process:1765): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
          Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
          [[email protected] tamara]# ”
          However installation followed as expected. Now it works!!!! ;) I really appreciate your guidance, JR.
          Txe.

          Reply
          • Excellent! You are welcome! :)

            Reply
    3. I installed skype following these instructions. I can get the sound but no video. Under Video Devices (Select webcam) it says “No devices found”. I am using fedora 16 64 bit. Please help. Thanks.
      Mike

      Reply
      • Hi Mike,

        Could you post output of following commands:

        
        lspci
        
        lsusb
        

        Is your webcam working normally with some other application under Linux?

        Reply
    4. Thanks. Yes, there was a problem with the webcam. A friend of mine suggested that I update fedora and reinstall skype. Everything works now. Thanks.
      Mike

      Reply
      • You are welcome! Excellent to hear that you got it working! :)

        Reply
    5. Great tutorial. I just switched from Ubuntu to CentOS and this really helped me out!

      Reply
    6. In fedora 17 x64 I only instal easylife , and install skype- it works very fine, a see my cam Micro$oft vx1000, so simple

      Reply
    7. and update /usr/bin/skype as following:


      I cannot update the /usr/bin/skype. I use vi, but all characters turn out to be @@@@@

      Reply
      • Hi wendylins,

        Sounds like your /usr/bin/skype file is binary file? How did you installed Skype?

        Reply
    8. /usr/bin/skype: /opt/skype/skype: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

      getting his error while starting skype…what to do ?

      Reply
      • Hi Satyajit,

        Could you post output of following commands:

        
        uname -a
        
        lsb_release -a
        
        Reply
    9. Linux user101 3.3.2-6.fc16.x86_64 #1 SMP Sat Apr 21 12:43:20 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
      
      
      LSB Version:	:core-4.0-amd64:core-4.0-noarch
      Distributor ID:	Fedora
      Description:	Fedora release 16 (Verne)
      Release:	16
      Codename:	Verne
      

      This is output of above commands

      Reply
      • Thanks, did you installed all 32-bit dependencies successfully on step 1.2?

        Reply
    10. Error: Protected multilib versions: libstdc++-4.6.3-2.fc16.i686 != libstdc++-4.6.2-1.fc16.x86_64
      Error: Protected multilib versions: libXi-1.4.5-1.fc16.i686 != libXi-1.4.3-3.fc16.x86_64
      Error: Protected multilib versions: zlib-1.2.5-7.fc16.i686 != zlib-1.2.5-6.fc16.x86_64
      Error: Protected multilib versions: 1:qt-4.8.2-4.fc16.i686 != 1:qt-4.8.1-5.fc16.x86_64
      Error: Protected multilib versions: alsa-lib-1.0.25-1.fc16.i686 != alsa-lib-1.0.24-2.fc15.x86_64
      Error: Protected multilib versions: glib2-2.30.3-1.fc16.i686 != glib2-2.30.1-1.fc16.x86_64
      Error: Protected multilib versions: 1:qt-x11-4.8.2-4.fc16.i686 != 1:qt-x11-4.8.1-5.fc16.x86_64

      i got this error at step 1.2 but still i continued my installation

      Reply
      • Okay, then try following:

        
        yum update
        
        yum clean all
        
        yum install alsa-lib.i686 fontconfig.i686 freetype.i686 glib2.i686 libSM.i686 libXScrnSaver.i686 libXi.i686 libXrandr.i686 libXrender.i686 libXv.i686 libstdc++.i686 pulseaudio-libs.i686 qt.i686 qt-x11.i686 zlib.i686
        

        Do you still get same error?

        Reply
    11. It works very well to the LiveUSB! Thanks! Thanks! Thanks!

      Reply
    12. Hi JR,

      as suggested by you. i did yum update yesterday.

      But now my system is not getting booted normally…i am booting system in recovery mode where i have to press Ctrl+D to start my system.

      What should i do.?

      i tried yum-complete-transaction
      yum clean all

      but not working.

      while booting.

      i see extra kernel in the list now.

      Help please.

      Reply
      • Hi Satyajit,

        Do you got any errors when you run yum update?

        Do you use example nVidia drivers?

        Could you test another (maybe older) kernel to boot?

        Could you also post output of following command (to http://pastebin.com):

        
        cat /boot/grub/grub.cfg
        
        Reply
        • Hi JR,

          I didnt got any error while updating.

          I am able to boot through my old kernel (recovery mode).

          Here is the output of commant

          output

          Reply
          • Hi Satyajit,

            Okay thanks, what errors you get when you try to boot with latest 3.4.9-2.fc16.x86_64 kernel?

            Reply
    13. Hi JR,

      I installed skype successfully on my fedora 16.

      At step 1.2, i was getting error for few packages. So instead of updating whole system with yum update, i just updated the packages for which i was getting error and it did work. Thanks :)

      Reply
      • Hi Satyajit,

        Excellent! :)

        Reply
    14. thanks for this..
      it works for me.
      CentOS 6.0

      Reply
    15. Keep functioning ,great job!

      Reply
1 2 3 4 5 25

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close