Install Chromium on CentOS/Red Hat (RHEL) 6.7 - Comment Page: 3

This is huide howto install Chromium Browser on CentOS 6 / Red Hat (RHEL) 6. Move directly to Chromium install guide. It's true Google Says Red Hat Enterprise Linux 6 Is Obsolete and after latest update, Google Chrome won't work anymore on CentOS 6/Red Hat (RHEL) 6. Someone might think that it's time to change Firefox or Opera, but if you have get used to Google Chrome, then it might be hard. Currently it might be possible to compile newer GCC and get Google Chrome working on Enterprise Linux 6, but more important news is that, the Google says Red Hat Enterprise Linux 6 Is Obsolete and later Google Chrome updates might need something new dependencies what Enterprise Linux 6 doesn't...

65 comments on “Install Chromium on CentOS/Red Hat (RHEL) 6.7 - Comment Page: 3

1 2 3 4
    1. It’s easy fast and works, many thanks!

      Reply
    2. Thanks for the guide! Installed on my CentOS 6.5 quick and easy.

      Reply
      • Hi John,

        Looks excellent, I updated this guide to use NCSU ITECS repository. Thanks.

        Reply
    3. I can’t install chromium :(

      Reply
      • Hi itxhelini,

        Could you tell a bit more about your problem?

        Reply
    4. Thanks, finally have chromium and back in business.
      Works like a charm, one of the things I like about RHEL in general.

      Reply
    5. Hi guys, so early I’ll not move to Centos 7, I’m using nscu repo that is working flawlessly, but I’m am brazilian and can’t accent characteres anymore since version 38, something with input method. Anyone with the same problem? I have a Fedora 20 notebook that is working fine.

      Reply
    6. I get this error on the last step (yum install chromium):

      Error: Package: chromiumlibs-runtime-1-9.el6.x86_64 (chromium)
      Requires: scl-utils
      Error: Package: chromium-39.0.2171.71-1.el6.x86_64 (chromium)
      Requires: libnss3.so(NSS_3.14.3)(64bit)
      Error: Package: chromiumlibs-glib2-2.36.3-4.el6.x86_64 (chromium)
      Requires: libz.so.1(ZLIB_1.2.2)(64bit)
      You could try using –skip-broken to work around the problem
      You could try running: rpm -Va –nofiles –nodigest

      Any idea why those required packages aren’t included or found?

      Reply
      • Hi dan,

        Are you using CentOS or RHEL?

        Could you post output of following commands:

        
        cat /etc/{centos,redhat}-release
        
        yum repolist
        
        Reply
        • Hey, I’m on Centos 6.2. Just noticed the article specifies 6.6, not sure if that will be an obstacle.

          Reply
          • Yes, I guess that you have to update your CentOS to get this working. Updating is actually very easy proceses, I have written short guide howto upgrade CentOS 6.

            Actually whole process is just:

            
            yum update
            

            But if you have some very important files (example configs) then it’s better backup those first.

            Then try this guide again.

            Reply
    7. I can get chromium to install fine, but where are you getting Pepper Flash? It doesn’t seem to be included.

      Reply
      • Hi E P,

        Apologies, but Pepper Flash is not included anymore. You can maybe extract it from Google Chrome rpm package, but it can’t be bundled on Chromium rpms, due to Adobe’s licensing.

        I updated this guide and removed part “with Pepper Flash”. If you need Pepper Flash, then you could try to checkout this Pepper Flash copy script and do same manually or modify script to work with needed Google Chrome rpm.

        Reply
    8. I have installed chromium succesfully..
      I cant run the installed chromium in both user and root..
      In root user
      it’ll display
      [code]
      please start chromium as a user.T run as root ,you must specify an alternate –user-data-dir for storage of profile information.
      [/code]

      In usermode it doesnt response for run this browser…..
      But when i run another browser in usermode response is already running .close that to use..After that i have tried by restrating the system …but nothing changed..
      give some tips friends…

      Reply
      • Hi pandiyan,

        Could you first post output of following commands (as normal user):

        
        px aux |grep chromium
        
        whoami
        
        ls -lad ~/{.config,.cache}/chromium/
        
        Reply
        • Hi ., I am also running in the same issue ..here are the outputs you requested :

          ps aux…
          957 0.0 0.0 0 0 ? Z Feb27 0:00 [chromium-browser]

          whoami

          ls -lad ~/{.config,.cache}/chromium/
          drwx——. 3 root 4096 Jan12 06:11 /home/user-directory/.cache/chromium
          drwx——. 3 root 4096 Jan12 06:11 /home/user-directory/.cache/chromium

          Reply
    9. worked like charm, thank you for assisting in installing chromium. keep posted for changes if any.

      Reply
    10. Thanks I need your style of teaching …. great!!!

      Reply
    11. super dude
      its is to simple i like it

      Reply
    12. i have installed chromium browser with this guide to centos 6.6 machine. But when i xrdp to it and click on chromium browser , nothing shows up.
      Also when i fire “chromium-browser” command in the commandline – it says successfully opened a new window.

      Can you please help !!

      thanks,
      poorva

      Reply
1 2 3 4

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close