If Not True Then False

Fedora 26/25/24 nVidia Drivers Install Guide - Comment Page: 50

This is guide, howto install nVidia proprietary drivers on Fedora 26/25/24/23/22/21 and disable Nouveau driver. This guide works with GeForce 6/7/8/9/200/300/400/500/600/700/800/900/10 series cards. GeForce 400/500/600/700/800/900/10 series cards works with 375.xx, 381.xx and 384.xx nVidia drivers GeForce 8/9/200/300 series cards works with 340.xx nVidia drivers GeForce 6/7 series cards works...
Categories:
Tagged with:

1374 Comments

Leave a Comment

Your email address will not be published. Required fields are marked *

Input your comment.
help

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Input your name.

Fares Bessrour

Thank you man, I’ve just switched for Debian based Distros to Fedora, I had an issue with the screen resolution not detecting my Native resolution and this fixed it. xrandr trick didn’t work this time for some reason.

Here’s my output:
“`bash
[seraf@localhost ~]$ nvidia-installer -v |grep version
nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06)
[seraf@localhost ~]$ uname -a
Linux localhost.localdomain 4.12.12-300.fc26.x86_64 #1 SMP Mon Sep 11 17:18:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[seraf@localhost ~]$ lspci |grep -E “VGA|3D”
01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1070] (rev a1)
“`

reply Reply
Felipe

$ nvidia-installer -v |grep version
nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06) Wed Aug 16 20:57:40 PDT 2017

$ uname -a
Linux new-host-2 4.12.11-300.fc26.x86_64 #1 SMP Thu Sep 7 18:32:12 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ lspci |grep -E “VGA|3D”
01:00.0 VGA compatible controller: NVIDIA Corporation GF114 [GeForce GTX 560 Ti] (rev a1)

I had to download the kernel-devel package from koji.fedoraproject.org since the current one was for a different kernel version, go figure.

reply Reply
JR

Hi Felipe,

Another way is update and reboot your computer and boot with latest kernel. Latest kernel should be same as latest kernel-devel package from repos.

reply Reply
Micah

FWIW, as I doubt I’ll have access to this system (ASUS ROG GX501V1-XS74) for long enough to actually troubleshoot this issue, running fully updated fresh install of Fedora, I’m hitting this error when running the latest driver installer (currently 384.69) during the installer:

ERROR: Unable to load the ‘nvidia-drm’ kernel module.

Quick googling has not been helpful. I’ve followed these instructions twice to be absolutely sure I didn’t miss a step. I’ll keep poking around and if someone randomly reposts in the next 30 minutes or so (:

Thanks for this post super helpful!

~Micah

reply Reply
Tom

$ nvidia-installer -v |grep version
nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06)

$ uname -a
Linux localhost.localdomain 4.12.12-300.fc26.x86_64 #1 SMP Mon Sep 11 17:18:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ lspci |grep -E “VGA|3D”
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)

reply Reply
Norbert Makula

nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06)
Linux deus-ex-machine 4.12.12-300.fc26.x86_64 #1 SMP Mon Sep 11 17:18:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
01:00.0 VGA compatible controller: NVIDIA Corporation GP108 [GeForce GT 1030] (rev a1)

Thank you for the guid

reply Reply
mprater

Worked great. Thank you so much for this information. It was extremely helpful.

[mprater@localhost ~]$ nvidia-installer -v | grep version
nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06) Wed Aug 16 20:57:40 PDT 2017
[mprater@localhost ~]$ uname -a
Linux localhost.localdomain 4.12.12-300.fc26.x86_64 #1 SMP Mon Sep 11 17:18:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[mprater@localhost ~]$ lspci | grep -E “VGA|3D”
05:00.0 VGA compatible controller: NVIDIA Corporation GF100GL [Quadro 4000] (rev a3)

reply Reply
Marco

Hello, I’m stuck at the passage of the reboot in runlevel 3. I’m asked my login name and password, but every combination I enter results in “incorrect login”. Now I don’t know what to do, can I somehow come back to runlevel 5? Please help me! :(

reply Reply
Martin

nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06)

Linux tatapa 4.12.13-300.fc26.x86_64 #1 SMP Thu Sep 14 16:00:38 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)

Very good Guide, Thanks, Martin

reply Reply
Krasimir Mikov

[kmikov@acer ~]$ nvidia-installer -v |grep version && uname -a && lspci | grep -E “VGA|3D”
nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06)
Linux acer 4.12.13-300.fc26.x86_64 #1 SMP Thu Sep 14 16:00:38 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940M] (rev a2)

Everything worked without a single error.

reply Reply
Dharamraj

Hello Krasimi Mikov, how did it worked for you. Looking at your output I also have Intel integrated graphics for VGA and Nvidia 840M graphics for 3D.
Can you help me?

reply Reply
Jason Schindler

nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06)

Linux localhost.localdomain 4.12.13-300.fc26.x86_64 #1 SMP Thu Sep 14 16:00:38 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

01:00.0 VGA compatible controller: NVIDIA Corporation GM107GLM [Quadro M1000M] (rev a2)

reply Reply
Daniël

Thanks again this time JR. I somehow always return here for the driver of my old 8800GS video-card. ;-)
After upgrading to Fedora 26:
– For kernel 4.11 the patched driver NVIDIA-Linux-x86_64-340.102-kernel-4.11-patched installs OK after the dialog “Ignore CC version check”.
– Trying to install NVIDIA-Linux-x86_64-340.102-kernel-4.12-patched I run into “Failed CC version check” never seen the “ignore CC version check” dialog.
It just fails. How can I skip the CC version check?

reply Reply
JR

Hi Daniël,

Could you post your /var/log/nvidia-installer.log?

reply Reply
Fernand LAMBERTS

[root@on4ly ~]# nvidia-installer -v |grep version
nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06)
[root@on4ly ~]# uname -a
Linux on4ly 4.12.13-300.fc26.x86_64 #1 SMP Thu Sep 14 16:00:38 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[root@on4ly ~]# lspci |grep -E “VGA|3D”
01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 660 Ti] (rev a1)
[root@on4ly ~]#

reply Reply
Roberto

[famram@home ~]$ nvidia-installer -v | grep version
nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06)
[famram@home ~]$ uname -a
Linux home.local 4.12.13-300.fc26.x86_64 #1 SMP Thu Sep 14 16:00:38 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[famram@home ~]$ lspci |grep -E “VGA|3D”
01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760] (rev a1)
[famram@home ~]$

steam is not running :(

reply Reply
Dharamraj

Hello Sir/Ma’am
I followed each and every step but when I launch nvidia-settings from terminal it gives error as unable to find display.
Please let me know how to solve this problem.
Thank you.

reply Reply
JR

Hi Dharamraj,

Is your nVidia drivers working normally and what versions you have installed?

reply Reply
Eli

Works great!
Thank you for your effort and a really good step by step guide.

Also, the output:
nvidia-installer -v |grep version
nvidia-installer: version 384.69 (buildmeister@swio-display-x86-rhel47-06) Wed Aug 16

uname -a
Linux g1bs0n 4.12.13-300.fc26.x86_64 #1 SMP Thu Sep 14 16:00:38 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

lspci |grep -E “VGA|3D”
01:00.0 VGA compatible controller: NVIDIA Corporation GF116 [GeForce GTX 550 Ti] (rev a1)

reply Reply