Fedora 31/30/29/28 nVidia Drivers Install Guide - Comment Page: 83

This is guide, howto install nVidia proprietary drivers on Fedora 31/30/29/28/27 and disable Nouveau driver. This guide works with GeForce 6/7/8/9/200/300/400/500/600/700/800/900/10/20 series cards. GeForce 20 series cards works with 418.xx, 430.xx, 435.xx and 440.xx nVidia drivers GeForce 600/700/800/900/10 series cards works with 390.xx, 418.xx, 430.xx, 435.xx and 440.xx nVidia drivers GeForce 400/500 series cards works with 390.xx nVidia drivers GeForce 8/9/200/300 series cards works with 340.xx nVidia drivers GeForce 6/7 series cards works with 304.xx nVidia drivers [inttf_post_ad1] This is totally different guide than my earlier guides, like Fedora 20 nVidia...

2,558 comments on “Fedora 31/30/29/28 nVidia Drivers Install Guide - Comment Page: 83

1 81 82 83 84 85 97
    1. Thank you. This solved a flickering screen issue on my three monitor setup that had been driving me nuts.

      version 415.27
      4.20.3-200.fc29.x86_64
      NVIDIA Corporation GK110 [GeForce GTX 780]

      Reply
    2. Wow!
      This guide really save my new linux box.
      Many thanks to you and keep up with the good work

      Reply
    3. bash-4.4$ nvidia-installer -v |grep version
      nvidia-installer: version 390.87 ([email protected])
      bash-4.4$
      bash-4.4$ uname -a
      Linux localhost.localdomain 4.20.5-200.fc29.x86_64 #1 SMP Mon Jan 28 19:29:17 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
      bash-4.4$
      bash-4.4$ lspci |grep -E “VGA|3D”
      01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 625 OEM] (rev a1)
      bash-4.4$

      Reply
    4. After all steps and reboot my system isn’t booting.

      I am new to linux and first time ever installed linux on my Dell N5110.

      Last message shown on screen is..

      [Ok] Started WPA supplicant.
      _

      Reply
      • Hi Nakul,

        Could you post output of following command:

        lspci |grep -E "VGA|3D"
        Reply
        • Hi I got this same message on a Legion Y720 laptop

          lspci |grep -E “VGA|3D”
          00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
          00:02.0 VGA compatible controller: NVIDIA Corporation GP106M (GeForce GTX 1060 Mobile) (rev a1)

          I did install the 430 drive and the installation finished with success. But I can’t boot
          The BIOS is booting with legacy mode

          Reply
          • Hi Ricardo,

            Looks like you have nVidia Optimus device? Drivers works, but you can’t run any desktop apps, you can do offscreen rendering only.

            Did you read step 1. Before nVidia drivers installation?

            Reply
    5. All nice, but…. how to install these drivers, if I don’t use GRUB ? I’m using rEFInd bootmanager. Yesterday – after trying to follow similar instruction – I’ve experienced rescue mode after reboot. Reconfiguring grub.cfg didn’t help, I had to reinstall whole F29.

      Any clues, please ?

      I know I might temporarily enable grub for installation process, and revert it back once done, but is there another way to disable nouveau ?

      Reply
      • Hi Martin,

        I think that it might work if you update your new initramfs on refind? If you have not grub2 installed at all, then just try blacklist nouveau on /etc/modprobe.d/blacklist.conf to see if it’s enough to disable nouveau?

        Reply
    6. nvidia-installer -v |grep version
      nvidia-installer: version 415.27

      uname -a
      Linux fedora-ws.lan 4.20.6-200.fc29.x86_64 #1 SMP Thu Jan 31 15:50:43 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

      lspci |grep -E “VGA|3D”
      01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)

      Hi, after installing the nvidia Driver I’ve trouble getting grub to show higher resolution than 1024×768. I’ve tried adding vga= and GFX_MODE. But both didn’t work.

      Has anybody similar problems?

      Reply
    7. $ nvidia-installer -v | grep version

      nvidia-installer: version 415.27

      $ uname -a

      Linux localhost.localdomain 4.20.6-200.fc29.x86_64 #1 SMP Thu Jan 31 15:50:43 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

      $ lspci | grep -E “VGA|3D”

      01:00.0 VGA compatible controller: NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev a1)

      Reply
    8. Hi, after installation nvidia panel does not run and I get an error from nvidia-settings
      I am running cinnamon 4 over fedora29:
      cinnamon-4.0.8-1.fc29

      During installation I don not get to “2.8.6 nVidia Installer Automatic Xorg Config and Backup”

      My configuration follows:
      $ nvidia-installer -v |grep version
      nvidia-installer: version 415.27

      $ uname -a
      Linux whitebase 4.20.7-200.fc29.x86_64 #1 SMP Wed Feb 6 19:16:42 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

      $ lspci |grep -E “VGA|3D”
      00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (Whiskey Lake)
      02:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)

      $ lsmod | grep -i nvid
      nvidia_drm 53248 0
      nvidia_modeset 1044480 1 nvidia_drm
      nvidia 17326080 1 nvidia_modeset
      ipmi_msghandler 69632 2 ipmi_devintf,nvidia
      drm_kms_helper 204800 2 nvidia_drm,i915
      drm 495616 5 drm_kms_helper,nvidia_drm,i915

      $ nvidia-smi
      Fri Feb 15 12:17:16 2019
      +—————————————————————————–+
      | NVIDIA-SMI 415.27 Driver Version: 415.27 CUDA Version: 10.0 |
      |——————————-+———————-+———————-+
      | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
      | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
      |===============================+======================+======================|
      | 0 GeForce MX150 Off | 00000000:02:00.0 Off | N/A |
      | N/A 56C P0 N/A / N/A | 0MiB / 2002MiB | 0% Default |
      +——————————-+———————-+———————-+

      +—————————————————————————–+
      | Processes: GPU Memory |
      | GPU PID Type Process name Usage |
      |=============================================================================|
      | No running processes found |
      +—————————————————————————–+

      $ nvidia-settings

      ERROR: Unable to load info from any available system

      $ ls -l /etc/X11/xorg.conf
      -rw-r–r–. 1 root root 0 Feb 5 13:16 /etc/X11/xorg.conf

      Reply
      • Hi Gianluca,

        You have nVidia Optimus device (https://www.geforce.com/hardware/notebook-gpus/geforce-mx150). If you check step 1.2 NVIDIA Optimus Technology then you see that problems might occur, because nVidia Optimus devices is not (fully) supported by nVidia’s Linux drivers. You can only do off screen rendering and run CUDA apps, but can’t run graphical environment. What you can do is check that if you can disable nVidia Optimus from BIOS/UEFI, then it might work.

        Reply
    9. Thank you!!

      [[email protected] ~]$ nvidia-installer -v |grep version
      nvidia-installer: version 410.93
      [[email protected] ~]$ uname -a
      Linux PCM 4.20.10-200.fc29.x86_64 #1 SMP Fri Feb 15 18:33:14 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
      [[email protected] ~]$ lspci |grep -E “VGA|3D”
      01:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] (rev a1)

      Reply
    10. Looks that 418.43 isn’t compatible. Had to use 415.27 on Fedora 29

      Reply
      • Hi trzeci,

        At least for me it works without problems. What problems do you have?

        Reply
    11. Great walk through, thanks.

      Suggest adding to 2.5 Dependencies
      dnf install kernel-devel kernel-headers gcc make dkms acpid libglvnd-glx libglvnd-opengl libglvnd-devel pkgconfig “kernel-devel-uname-r == $(uname -r)” .

      Until I did that, I was running into issues with
      /usr/sbin/dkms build -m nvidia -v 418.43 -k 4.18.16-300.fc29.x86_64
      Error! echo
      Your kernel headers for kernel 4.18.16-300.fc29.x86_64 cannot be found at
      /lib/modules/4.18.16-300.fc29.x86_64/build or /lib/modules/4.18.16-300.fc29.x86_64/source

      Reply
      • Hello No Body,

        Actually this is not needed if you follow guide. Check step, 2.4 Make sure that you system is up-to-date and you are running latest kernel, when you “dnf update” your system and reboot using latest kernel, then you can simply install latest kernel-devel.

        Reply
    12. Today I updated my kernel to version 4.20.12-200.fc29.x86_64. Unfortunately dkms was not able to update the kernel module, due to a recent update of gcc to version 8.3.something. The kernel was compiled with version 8.2.1, so a gcc mismatch was reported in the logs.

      My solution was to downgrade gcc by installing it with
      ‘sudo dnf install gcc-8.2.1’.
      You could also install gcc 8.2.1 in another directory and set the cc environmental variable accordingly.
      Check your gcc version.
      ‘gcc –version’

      Than I invoked the dkms build process with
      ‘sudo dkms build nvidia/418.43 -k 4.20.12-200.fc29.x86_64’
      and installed it with
      ‘sudo dkms install nvidia/418.43 -k 4.20.12-200.fc29.x86_64’.
      Note that you have to adjust your kernel and driver version.
      You can check the installation with
      ‘dkms status’

      If you already have the issue that you can not boot, switch to an older installed kernel or the fedora rescue mode.

      My current state:
      nvidia-installer: version 418.43

      01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1080] (rev a1)

      Linux beteigeuze 4.20.12-200.fc29.x86_64 #1 SMP Mon Feb 25 16:16:18 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

      Greetings

      Reply
      • It seems odd that fedora would put users in this situation. I ran into the same issue. Why are they including gcc-8.3.1 in the repos when the kernel latest kernel they’re providing was built with gcc-8.2.1? Shouldn’t they be recompiling the kernel with gcc-8.3.1?

        Reply
        • Hi Mario, Nils and Brian,

          This is always temporary, but unfortunately can happen. Fedora is open source project where different developers compile gcc and kernels. This is fixed on next kernel build and can be also fixed using IGNORE_CC_MISMATCH=1 environment variable when you run installer.

          Reply
          • Hi JR,

            yes you are correct and it seems definitely less annoying to use the IGNORE_CC_MISMATCH parameter. But from my knowledge it is commonly advised against using different compiler versions for kernel and kernel modules, because it could potentially break things and give you some headache in the future. On the other hand, I’ve never tested that myself and it is probably a bigger concern with higher release versions, like for example gcc-7 vs gcc-8. Anyway downgrading seems a bit safer for me

            Greetings

            Reply
            • Hi Nils,

              You are right it might cause problems sometimes, so downgrading gcc or recompiling kernel might be much better options.

              Btw. Looks like latest version needs --no-cc-version-check instead of IGNORE_CC_MISMATCH environment variable.

              Just updated this guide and tested all versions and added screenshots.

              Reply
      • Thanks a lot! Solved the problem for 390.87 driver. I actually just post a question here; I should read your post first :)

        Reply
    13. [[email protected] ~]$ nvidia-installer -v | grep version
      nvidia-installer: version 418.43
      [[email protected] ~]$ uname -a
      Linux localhost.localdomain 4.16.3-301.fc28.x86_64 #1 SMP Mon Apr 23 21:59:58 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
      [[email protected] ~]$ lspci | grep -E ‘VGA|3D’
      00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
      04:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940M] (rev a2)
      [[email protected] ~]$

      i’m using ASUS K555L laptop

      Reply
    14. Thanks very much for the hint. I had the same exact issue. I just installed gcc-8.2.1 then switched to multi-user.target and run the 418 nvidia latest driver with root and worked fine.

      Reply
    15. Thanks for the tutorial it works great with kernel 4.20.8-200.fc29.x86_64.

      Just a few questions, does these installation steps modify something in your initramfs image? or why do we need to backup the img?

      I’m facing problems when updating to kernel 4.20.13-200.fc29.x86_64 i’m wondering if i need to do some modifications in my initramfs image initramfs-4.20.13-200.fc29.x86_64.img also.

      The problem:
      I have encrypted my data, so after typing my password the loading marks change color to orange and freezes out, i tried switching to anoter tty(ctrl + alt + F3) but i can only see the cursor.

      Thanks for the tutorial again, best regards.

      Reply
      • Hi Miguel,

        What kind of problem you have? You might see gcc mismatch error? You can run IGNORE_CC_MISMATCH=1 /path/to/your-nvidia-installer.

        Reply
        • I tried this (IGNORE_CC_MISMATCH=1 /path/to/your-nvidia-installer) and it worked.

          Linux 4.20.13-200.fc29.x86_64 #1 SMP Wed Feb 27 19:42:55 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

          nvidia-installer: version 390.116 ([email protected]) Sun Jan 27 07:48:10 PST 2019

          Reply
1 81 82 83 84 85 97

Leave a Reply to Ricardo Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close