Fedora 30/29/28 nVidia Drivers Install Guide - Comment Page: 90

This is guide, howto install nVidia proprietary drivers on Fedora 30/29/28/27/26/25/24/23 and disable Nouveau driver. This guide works with GeForce 6/7/8/9/200/300/400/500/600/700/800/900/10/20 series cards. GeForce 20 series cards works with 418.xx, 430.xx and 435.xx nVidia drivers GeForce 600/700/800/900/10 series cards works with 390.xx, 418.xx, 430.xx and 435.xx nVidia drivers GeForce 400/500 series cards works with 390.xx nVidia drivers GeForce 8/9/200/300 series cards works with 340.xx nVidia drivers GeForce 6/7 series cards works with 304.xx nVidia drivers [inttf_post_ad1] This is totally different guide than my earlier guides, like Fedora 20 nVidia driver...

2,478 comments on “Fedora 30/29/28 nVidia Drivers Install Guide - Comment Page: 90

1 88 89 90 91 92 94
    1. Hi, my install failed when I got bumped to kennel 5.1.6 with the following Dkms error.

      Dkms tree already contains nvidia-430.14, you cannot add the same module/version combo more than once. I tried –uninstall which was successful but upon trying to install again, same Dkms problem. I also tried ‘Dkms remove’, same error.

      Reply
    2. Hi, I’ve successfully installed the driver, but now the boot time is very long.

      systemd-analyze blame
      returns:

      1min 41.181s plymouth-quit-wait.service
      1min 10.713s dkms.service

      I’ve followed the guide to restore Plymouth but it didn’t work.
      Any idea? Thanks.

      nvidia-installer: version 430.14

      Linux localhost.localdomain 5.1.6-300.fc30.x86_64 #1 SMP Fri May 31 17:43:23 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

      01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)

      Reply
      • Hi Orson,

        Do you get same over minute waits on every boot? When dkms is compiling new driver this might be normal, but shouldn’t happen on every boot.

        Reply
    3. fixed myself ^^^, after running uninstall i ran:

      rm -rf /var/lib/dkms/nvidia/

      installed again, all good

      Reply
    4. Sucesso na instalação:

      [[email protected] ~]# nvidia-installer -v |grep version

      nvidia-installer: version 430.14

      [[email protected] ~]# uname -a

      Linux localhost.localdomain 5.1.6-300.fc30.x86_64 #1 SMP Fri May 31 17:43:23 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

      [[email protected] ~]# lspci |grep -E “VGA|3D”

      00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (Whiskey Lake)
      02:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)

      Reply
    5. Fresh install without problems:

      nvidia-installer: version 430.14

      Linux MyFedora 5.1.6-300.fc30.x86_64 #1 SMP Fri May 31 17:43:23 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

      01:00.0 VGA compatible controller: NVIDIA Corporation GP104GLM [Quadro P3200 Mobile] (rev a1)

      Reply
    6. On F30 it failed with this error: unable to load the nvidia-drm kernel module

      =====================================
      [[email protected] ~]$ lspci |grep -E “VGA | 3D”
      01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GTX 650] (rev a1)
      [[email protected] ~]$ cat /etc/*release*
      Fedora release 30 (Thirty)
      NAME=Fedora
      VERSION=”30 (Workstation Edition)”
      ID=fedora
      VERSION_ID=30
      VERSION_CODENAME=””
      PLATFORM_ID=”platform:f30″
      PRETTY_NAME=”Fedora 30 (Workstation Edition)”
      ANSI_COLOR=”0;34″
      LOGO=fedora-logo-icon
      CPE_NAME=”cpe:/o:fedoraproject:fedora:30″
      HOME_URL=”https://fedoraproject.org/”
      DOCUMENTATION_URL=”https://docs.fedoraproject.org/en-US/fedora/f30/system-administrators-guide/”
      SUPPORT_URL=”https://fedoraproject.org/wiki/Communicating_and_getting_help”
      BUG_REPORT_URL=”https://bugzilla.redhat.com/”
      REDHAT_BUGZILLA_PRODUCT=”Fedora”
      REDHAT_BUGZILLA_PRODUCT_VERSION=30
      REDHAT_SUPPORT_PRODUCT=”Fedora”
      REDHAT_SUPPORT_PRODUCT_VERSION=30
      PRIVACY_POLICY_URL=”https://fedoraproject.org/wiki/Legal:PrivacyPolicy”
      VARIANT=”Workstation Edition”
      VARIANT_ID=workstation
      Fedora release 30 (Thirty)
      Fedora release 30 (Thirty)
      cpe:/o:fedoraproject:fedora:30
      [[email protected] ~]$

      Reply
      • Hi Jorge,

        What nvidia drivers version you tried to install and what kernel you used?

        Reply
    7. Hi Team, The most current Nvidia 390.xx legacy drivers available as of now being the 390.116 (February 22, 2019) release from Nvidia’s site do NOT build with the current Linux Kernel 5.1.x. The error you will get is: error redefinition of “list_is_first”

      Via RPM Fusion I found two patch files that are required to make this Legacy NVidia 390.xx driver release build, install and run for the 5.1.x kernels. I built a NVIDIA-Linux-x86_64-390.116.patched.run package that I have personally tested with the latest Fedora Linux Kernel 5.1.7-300.fc30.

      I have sent you a link to download the patched and tested NVidia package in the standard *.run format for Linux.

      The link to download is from my onw business website (100% safe):
      https://www.peterboweycomputerservices.com.au/support/NVIDIA-Linux-x86_64-390.116.patched.run

      If you are interested I have added the two essential patch files required to use this 390.xx series driver with any Linux kernel 5.1.x.

      I hope this helps other ‘frustrated’ users who are having the same issues I did since the latest three 5.1.x Kernel releases. The build error “error redefinition of “list_is_first”” – and then you had to revert to building with the older (retired) 5.0.x Kernel.

      Patch #1: https://www.peterboweycomputerservices.com.au/support/kernel-5.1_pt1.patch

      Patch #2:
      https://www.peterboweycomputerservices.com.au/support/kernel-5.1_pt2.patch

      Please note I built and tested the linked *.run file using makeself.sh ./NVIDIA-Linux-x86_64-390.116 NVIDIA-Linux-x86_64-390.116.patched.run “Patched NVidia Legacy 390 driver for 5.1 Kernels” ./nvidia-installer

      I tested the above linked “*.run” package live on my own workstation on the 11th June 2019 – after the latest Linux kernel release 5.1.7-300.

      Regards,
      Peter Bowey

      Reply
    8. Hi,

      Is there going to be a 340.107 patch for kernel 5.1?

      Cheers
      Sam

      Reply
      • Also need the patched 340.107 for kernel 5.1. For now I can only stay at 5.0. Thank you!

        Reply
    9. Thanks for your excellent web site and instructions. They have been working pretty well for several versions of the Fedora kernel. But the upgrade to 5.1.6-200.fc29 kernel failed. (I usually have issues when the minor version number changes, but my work-arounds won’t work this time.) I’m using the Nvidia 390.116 modules (GeForce GT 420).

      There was a compiler error in the nvidia-installer.log file. It has disappeared when I had to recompile to revert to 5.0.17. I can regenerate and send this to you if it is useful.

      Reply
      • Hi Michael,

        I just updated guide and added Nvidia 390.116 patched version for kernel 5.1.8.

        Reply
    10. Works like a charm.
      Thanks!

      nvidia-installer: version 430.26
      5.1.8-300.fc30.x86_64 #1 SMP Sun Jun 9 17:09:32 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
      01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1070 Ti] (rev a1)

      Reply
    11. succeed! if you like to have the screenshot how can i send it to you?

      Reply
    12. Hi,

      same situation here with 5.1.8-200.fc29.x86_64
      for NVIDIA GT215 [GeForce GT 240] (rev a2).
      Latest patched kernel inefficient.
      I’ve read Kevin’s answer, no /var/lib/dkms/nvidia/ directory on my system (maybe I’ve missed something).
      Havce a good day ;)

      Reply
      • I’ve done with the new patch, working fine.
        Thanks a lot ;o)

        Reply
        • Excellent, you are welcome!

          Reply
    13. Hi,

      Followed by tutorial with my mi gaming laptop
      (nvidia-gtx-1060) very carefully. At the beginning of installation was prompted to remove previously installed fusion-nvidia drivers, which I did and everything seemed to going well. Now, when I’m trying to boot, right after fedora logo I see the stack-trace of enabling modules and it stuck on “Started WPA supplicant” forever. No error messages, no warnings during installation or anything. Could you please provide me with some info, what can I do with that problem.

      Thanks!

      Reply
      • Hi Anthony,

        Could you post output of following command:

        lspci |grep -E "VGA|3D"
        Reply
    14. I also found that under FC30 the console would hang during the first boot after a kernel update. I traced this to GDM now starting before DKMS has had a chance to build the new nvidia drivers. Indeed you can SSH onto it from another system, wait until DKMS is finished, and then “systemctl restart gdm” (or just reboot it). The actual DKMS process is fine – it’s just GDM starting too early. Unfortunately the DKMS service is oneshot so not sure what the best answer is.

      Reply
      • Hi Chris,

        I actually noticed same style behavior with some kernel update. This have to be changed lately. Have to check is this already fixed or maybe reported on bugzilla.

        Reply
1 88 89 90 91 92 94

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close