Install NVIDIA [515.76 / 510.85.02 / 470.141.03 / 390.154 / 340.108] Drivers on Debian / Ubuntu / Linux Mint / LMDE - Comment Page: 4

This is guide, howto install NVIDIA proprietary drivers (manually using .run files) on Debian Sid/11/10, Ubuntu 22.04/21.10/21.04/20.10, Linux Mint 20.3 / 20.2 / 20.1, LMDE 4 and disable Nouveau driver. This guide works with GeForce 8/9/200/300/400/500/600/700/800/900/10/20/30 series cards. This is alternative way to install NVIDIA drivers, because Debian based Linux distros have NVIDIA drivers directly from repos too. GeForce RTX 30 series cards works with 515.xx, 510.xx, 470.xx NVIDIA drivers, (RTX 3090, RTX 3080, RTX 3070, RTX 3060 Ti, RTX 3060) GeForce RTX 20 series cards works with 515.xx, 510.xx, 470.xx NVIDIA drivers (RTX 2080 Ti, RTX 2080, RTX 2070 Ti, RTX 2070, RTX 2060) ...

76 comments on “Install NVIDIA [515.76 / 510.85.02 / 470.141.03 / 390.154 / 340.108] Drivers on Debian / Ubuntu / Linux Mint / LMDE - Comment Page: 4

1 2 3 4
    1. It does not work for me. Xorg log states that: “This server has a video driver ABI version of 25.2 that this driver does not officially support….
      (WW) NVIDIA: The driver will continue to load, but may behave strangely.
      (WW) NVIDIA: This driver was compiled against the X.Org server SDK from commit e6ef2b12404dfec7f23592a3524d2a63d9d25802 and may not be compatible with the final version of this SDK.”. As I understand
      the mentioned above commit is X v1.20 when my version of X is 1.21.
      >nvidia-installer -v

      nvidia-installer: version 340.108 ([email protected]) Wed Dec 11 15:13:39 PST 2019

      > cat /etc/lsb-release
      DISTRIB_ID=Ubuntu
      DISTRIB_RELEASE=22.04
      DISTRIB_CODENAME=jammy
      DISTRIB_DESCRIPTION=”Ubuntu 22.04.1 LTS
      > lspci |grep -E “VGA|3D”
      01:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce GTS 250] (rev a2)

      Reply
      • Hello Arkady,

        Try to add following to your /etc/X11/xorg.conf:

        Section "ServerFlags"
          Option "IgnoreABI" "1"
        EndSection

        It should work, I update this guide and test Ubuntu 22.10 too with this, if it’s possible to get it working.

        Reply
    2. I found the debian apt autoremove line didn’t remove enough stuff. I changed it to “apt autoremove $(dpkg -l nvidia-* |grep ii |awk ‘{print $2}’)”. This was actually after ran “nvidia-smi -pm 0” which was still using nvidia_modeset and then manually removed the nvidia modules but that probably isn’t needed if you uninstall all the nvidia packages.

      Thanks for the very detailed write up. Helped a lot since apparently Proton experimental requires 510.47 and up to work.

      Reply
1 2 3 4

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Close